summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-04-19 20:00:35 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-04-19 20:00:35 +0000
commit38bba6b265b4a15f5076277cd83d52c49e8263c3 (patch)
treefdf6dc4f784135e52d54201a4bf30017cae69f8c /dev-libs/zthread
parent- update for cross compile. Fixes bug 193902 (diff)
downloadgentoo-2-38bba6b265b4a15f5076277cd83d52c49e8263c3.tar.gz
gentoo-2-38bba6b265b4a15f5076277cd83d52c49e8263c3.tar.bz2
gentoo-2-38bba6b265b4a15f5076277cd83d52c49e8263c3.zip
Patch so that -fpermissive is not needed to build. Thanks to Wilfried Holzke <gentoo AT holzke DOT net>; bug #232645
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/zthread')
-rw-r--r--dev-libs/zthread/ChangeLog11
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-no-fpermissive.diff94
-rw-r--r--dev-libs/zthread/zthread-2.3.2-r1.ebuild48
3 files changed, 151 insertions, 2 deletions
diff --git a/dev-libs/zthread/ChangeLog b/dev-libs/zthread/ChangeLog
index 134aec4e005e..6a925193bb3b 100644
--- a/dev-libs/zthread/ChangeLog
+++ b/dev-libs/zthread/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/zthread
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/ChangeLog,v 1.22 2007/09/24 21:22:15 dev-zero Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/ChangeLog,v 1.23 2009/04/19 20:00:34 halcy0n Exp $
+
+*zthread-2.3.2-r1 (19 Apr 2009)
+
+ 19 Apr 2009; Mark Loeser <halcy0n@gentoo.org>
+ +files/zthread-2.3.2-no-fpermissive.diff, +zthread-2.3.2-r1.ebuild:
+ Patch so that -fpermissive is not needed to build. Thanks to Wilfried
+ Holzke <gentoo AT holzke DOT net>; bug #232645
*zthread-2.3.2 (24 Sep 2007)
diff --git a/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive.diff b/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive.diff
new file mode 100644
index 000000000000..21fad7c52c8e
--- /dev/null
+++ b/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive.diff
@@ -0,0 +1,94 @@
+--- include/zthread/Guard.h.orig 2008-07-22 14:46:28.000000000 +0200
++++ include/zthread/Guard.h 2008-07-22 14:51:41.000000000 +0200
+@@ -491,7 +491,7 @@
+
+ try {
+
+- if(!isDisabled())
++ if(!LockHolder<LockType>::isDisabled())
+ LockingPolicy::destroyScope(*this);
+
+ } catch (...) { /* ignore */ }
+--- src/MutexImpl.h.orig 2008-07-22 14:54:40.000000000 +0200
++++ src/MutexImpl.h 2008-07-22 15:03:30.000000000 +0200
+@@ -153,7 +153,7 @@
+
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List,Behavior>::ownerAcquired(self);
+
+ }
+
+@@ -164,7 +164,7 @@
+ _waiters.insert(self);
+ m.acquire();
+
+- waiterArrived(self);
++ MutexImpl<List, Behavior>::waiterArrived(self);
+
+ {
+
+@@ -173,7 +173,7 @@
+
+ }
+
+- waiterDeparted(self);
++ MutexImpl<List, Behavior>::waiterDeparted(self);
+
+ m.release();
+
+@@ -192,7 +192,7 @@
+ assert(_owner == 0);
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List, Behavior>::ownerAcquired(self);
+
+ break;
+
+@@ -236,7 +236,7 @@
+
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List, Behavior>::ownerAcquired(self);
+
+ }
+
+@@ -253,7 +253,7 @@
+
+ m.acquire();
+
+- waiterArrived(self);
++ MutexImpl<List, Behavior>:: waiterArrived(self);
+
+ {
+
+@@ -262,7 +262,7 @@
+
+ }
+
+- waiterDeparted(self);
++ MutexImpl<List, Behavior>::waiterDeparted(self);
+
+ m.release();
+
+@@ -284,7 +284,7 @@
+ assert(0 == _owner);
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List, Behavior>::ownerAcquired(self);
+
+ break;
+
+@@ -326,7 +326,7 @@
+
+ _owner = 0;
+
+- ownerReleased(impl);
++ MutexImpl<List, Behavior>::ownerReleased(impl);
+
+ // Try to find a waiter with a backoff & retry scheme
+ for(;;) {
diff --git a/dev-libs/zthread/zthread-2.3.2-r1.ebuild b/dev-libs/zthread/zthread-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..17ac32b72a07
--- /dev/null
+++ b/dev-libs/zthread/zthread-2.3.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/zthread-2.3.2-r1.ebuild,v 1.1 2009/04/19 20:00:34 halcy0n Exp $
+
+inherit flag-o-matic eutils
+
+MY_P="ZThread-${PV}"
+
+DESCRIPTION="A platform-independent multi-threading and synchronization library for C++"
+HOMEPAGE="http://zthread.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zthread/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="debug doc kernel_linux"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-fpermissive.diff
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable kernel_linux atomic-linux) \
+ || die "configure failed"
+ emake || die "make failed"
+
+ if use doc ; then
+ doxygen doc/zthread.doxygen || die "generating docs failed"
+ cp ./doc/documentation.html ./doc/html/index.html
+ cp ./doc/zthread.css ./doc/html/zthread.css
+ cp ./doc/bugs.js ./doc/html/bugs.js;
+ fi
+}
+
+src_install() {
+ # Uses it's own install-hooks and ignores DESTDIR
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog README NEWS TODO
+ use doc && dohtml doc/html/*
+}