summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-02-11 18:41:01 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-02-11 18:41:01 +0000
commitb41320e4f85ebb57c8d2975d28c23f4bf5e6aadd (patch)
treeda8d3420486c7dd9f9dae95efdd17dac9dda6d5e /dev-libs/yajl
parentStable on amd64 wrt bug #353737 (diff)
downloadgentoo-2-b41320e4f85ebb57c8d2975d28c23f4bf5e6aadd.tar.gz
gentoo-2-b41320e4f85ebb57c8d2975d28c23f4bf5e6aadd.tar.bz2
gentoo-2-b41320e4f85ebb57c8d2975d28c23f4bf5e6aadd.zip
Fix static linking and tests per Diego's request.
(Portage version: 2.2.0_alpha21/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/yajl')
-rw-r--r--dev-libs/yajl/ChangeLog8
-rw-r--r--dev-libs/yajl/files/yajl-fix_static_linking.patch24
-rw-r--r--dev-libs/yajl/yajl-1.0.11-r1.ebuild30
-rw-r--r--dev-libs/yajl/yajl-1.0.11.ebuild6
4 files changed, 64 insertions, 4 deletions
diff --git a/dev-libs/yajl/ChangeLog b/dev-libs/yajl/ChangeLog
index 4a00e7583793..75869d76c102 100644
--- a/dev-libs/yajl/ChangeLog
+++ b/dev-libs/yajl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/yajl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/ChangeLog,v 1.7 2011/02/03 17:50:46 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/ChangeLog,v 1.8 2011/02/11 18:41:01 scarabeus Exp $
+
+*yajl-1.0.11-r1 (11 Feb 2011)
+
+ 11 Feb 2011; Tomáš Chvátal <scarabeus@gentoo.org> yajl-1.0.11.ebuild,
+ +yajl-1.0.11-r1.ebuild, +files/yajl-fix_static_linking.patch:
+ Fix static linking and tests per Diego's request.
03 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> yajl-1.0.11.ebuild:
Added ~ppc/~ppc64 wrt #341149
diff --git a/dev-libs/yajl/files/yajl-fix_static_linking.patch b/dev-libs/yajl/files/yajl-fix_static_linking.patch
new file mode 100644
index 000000000000..56bf0e737319
--- /dev/null
+++ b/dev-libs/yajl/files/yajl-fix_static_linking.patch
@@ -0,0 +1,24 @@
+diff -urN lloyd-yajl-f4baae0.old//reformatter/CMakeLists.txt lloyd-yajl-f4baae0//reformatter/CMakeLists.txt
+--- lloyd-yajl-f4baae0.old//reformatter/CMakeLists.txt 2010-07-22 00:12:15.000000000 +0200
++++ lloyd-yajl-f4baae0//reformatter/CMakeLists.txt 2011-02-11 19:28:40.006756997 +0100
+@@ -42,7 +42,7 @@
+
+ ADD_EXECUTABLE(json_reformat ${SRCS})
+
+-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
++TARGET_LINK_LIBRARIES(json_reformat yajl)
+
+ # copy the binary into the output directory
+ GET_TARGET_PROPERTY(binPath json_reformat LOCATION)
+diff -urN lloyd-yajl-f4baae0.old//verify/CMakeLists.txt lloyd-yajl-f4baae0//verify/CMakeLists.txt
+--- lloyd-yajl-f4baae0.old//verify/CMakeLists.txt 2010-07-22 00:12:15.000000000 +0200
++++ lloyd-yajl-f4baae0//verify/CMakeLists.txt 2011-02-11 19:28:58.296756998 +0100
+@@ -42,7 +42,7 @@
+
+ ADD_EXECUTABLE(json_verify ${SRCS})
+
+-TARGET_LINK_LIBRARIES(json_verify yajl_s)
++TARGET_LINK_LIBRARIES(json_verify yajl)
+
+ # copy in the binary
+ GET_TARGET_PROPERTY(binPath json_verify LOCATION)
diff --git a/dev-libs/yajl/yajl-1.0.11-r1.ebuild b/dev-libs/yajl/yajl-1.0.11-r1.ebuild
new file mode 100644
index 000000000000..cf53b7068311
--- /dev/null
+++ b/dev-libs/yajl/yajl-1.0.11-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-1.0.11-r1.ebuild,v 1.1 2011/02/11 18:41:01 scarabeus Exp $
+
+EAPI=3
+
+inherit cmake-utils
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="http://lloyd.github.com/yajl/"
+SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+src_prepare() {
+ cd "${WORKDIR}"/lloyd-${PN}-*
+ S=$(pwd)
+
+ epatch "${FILESDIR}"/${PN}-fix_static_linking.patch
+}
+
+src_test() {
+ pushd "${CMAKE_BUILD_DIR}" > /dev/null
+ emake test
+ popd > /dev/null
+}
diff --git a/dev-libs/yajl/yajl-1.0.11.ebuild b/dev-libs/yajl/yajl-1.0.11.ebuild
index a2b1a2017bc2..7b0439cb7d00 100644
--- a/dev-libs/yajl/yajl-1.0.11.ebuild
+++ b/dev-libs/yajl/yajl-1.0.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-1.0.11.ebuild,v 1.6 2011/02/03 17:50:46 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-1.0.11.ebuild,v 1.7 2011/02/11 18:41:01 scarabeus Exp $
-EAPI="2"
+EAPI=2
inherit cmake-utils
@@ -26,5 +26,5 @@ src_prepare() {
}
src_test() {
- emake test || die
+ emake test
}