summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2006-08-12 09:50:36 +0000
committerBenedikt Boehm <hollow@gentoo.org>2006-08-12 09:50:36 +0000
commitb954bb54e549f05ad4fc670381e6419490a8345f (patch)
treeb73536abc7f09a30c77b28326655bf9fd0d944e1 /dev-libs/xmlrpc-c
parentnew upstream release. (diff)
downloadgentoo-2-b954bb54e549f05ad4fc670381e6419490a8345f.tar.gz
gentoo-2-b954bb54e549f05ad4fc670381e6419490a8345f.tar.bz2
gentoo-2-b954bb54e549f05ad4fc670381e6419490a8345f.zip
fix previous patch for optional client libs
(Portage version: 2.1.1_pre4-r3)
Diffstat (limited to 'dev-libs/xmlrpc-c')
-rw-r--r--dev-libs/xmlrpc-c/ChangeLog6
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch54
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.06.03.ebuild4
3 files changed, 61 insertions, 3 deletions
diff --git a/dev-libs/xmlrpc-c/ChangeLog b/dev-libs/xmlrpc-c/ChangeLog
index ca868860ca36..5c95bcd6f7e2 100644
--- a/dev-libs/xmlrpc-c/ChangeLog
+++ b/dev-libs/xmlrpc-c/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/xmlrpc-c
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/ChangeLog,v 1.17 2006/08/12 07:37:06 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/ChangeLog,v 1.18 2006/08/12 09:50:36 hollow Exp $
+
+ 12 Aug 2006; Benedikt Böhm <hollow@gentoo.org>
+ files/xmlrpc-c-1.06.03-mustbuildclient.patch, xmlrpc-c-1.06.03.ebuild:
+ fix previous patch for optional client libs
*xmlrpc-c-1.06.03 (12 Aug 2006)
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch
index f4c600b6887c..4ceb2e8fbfb3 100644
--- a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch
@@ -95,3 +95,57 @@ Index: xmlrpc-c-1.06.03/tools/Makefile
.PHONY: all clean distclean install check dep
+Index: xmlrpc-c-1.06.03/xmlrpc-c-config.in
+===================================================================
+--- xmlrpc-c-1.06.03.orig/xmlrpc-c-config.in
++++ xmlrpc-c-1.06.03/xmlrpc-c-config.in
+@@ -108,26 +108,31 @@ while test $# -gt 0; do
+ ;;
+ client|libwww-client)
+ # libwww-client is for backward compatibility
+- the_libs="-lxmlrpc_client $the_libs"
+
+- if test "${MUST_BUILD_WININET_CLIENT}" = "yes"; then
+- the_libs="@WININET_LDADD@ $the_libs"
+- the_rpath="@WININET_RPATH@ $the_rpath"
+- the_wl_rpath="@WININET_WL_RPATH@ $the_wl_rpath"
+- fi
+- if test "${MUST_BUILD_CURL_CLIENT}" = "yes"; then
+- the_libs="@CURL_LDADD@ $the_libs"
+- the_rpath="@CURL_RPATH@ $the_rpath"
+- the_wl_rpath="@CURL_WL_RPATH@ $the_wl_rpath"
+- fi
+- if test "${MUST_BUILD_LIBWWW_CLIENT}" = "yes"; then
+- the_libs="@LIBWWW_LDADD@ $the_libs"
+- the_rpath="@LIBWWW_RPATH@ $the_rpath"
+- the_wl_rpath="@LIBWWW_WL_RPATH@ $the_wl_rpath"
+- fi
+- if test "${needCpp}" = "yes"; then
+- the_libs="-lxmlrpc_client++ $the_libs"
++ if test "${MUST_BUILD_WININET_CLIENT}" = "yes" || \
++ test "${MUST_BUILD_CURL_CLIENT}" = "yes" || \
++ test "${MUST_BUILD_LIBWWW_CLIENT}" = "yes"; then
++ the_libs="-lxmlrpc_client $the_libs"
++
++ if test "${MUST_BUILD_WININET_CLIENT}" = "yes"; then
++ the_libs="@WININET_LDADD@ $the_libs"
++ the_rpath="@WININET_RPATH@ $the_rpath"
++ the_wl_rpath="@WININET_WL_RPATH@ $the_wl_rpath"
+ fi
++ if test "${MUST_BUILD_CURL_CLIENT}" = "yes"; then
++ the_libs="@CURL_LDADD@ $the_libs"
++ the_rpath="@CURL_RPATH@ $the_rpath"
++ the_wl_rpath="@CURL_WL_RPATH@ $the_wl_rpath"
++ fi
++ if test "${MUST_BUILD_LIBWWW_CLIENT}" = "yes"; then
++ the_libs="@LIBWWW_LDADD@ $the_libs"
++ the_rpath="@LIBWWW_RPATH@ $the_rpath"
++ the_wl_rpath="@LIBWWW_WL_RPATH@ $the_wl_rpath"
++ fi
++ if test "${needCpp}" = "yes"; then
++ the_libs="-lxmlrpc_client++ $the_libs"
++ fi
++ fi
+ ;;
+ --version)
+ echo "@VERSION@"
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.06.03.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.06.03.ebuild
index 9b0c227e1e5b..6850d578a127 100644
--- a/dev-libs/xmlrpc-c/xmlrpc-c-1.06.03.ebuild
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.06.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.06.03.ebuild,v 1.1 2006/08/12 07:37:06 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.06.03.ebuild,v 1.2 2006/08/12 09:50:36 hollow Exp $
inherit eutils
@@ -35,7 +35,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.05-pic.patch
epatch "${FILESDIR}"/${PN}-1.06.02-threadupdatestatus.patch
epatch "${FILESDIR}"/${PN}-1.06.02-strsol.patch
- epatch "${FILESDIR}"/${PN}-1.06.03-cppmustbuildclient.patch
+ epatch "${FILESDIR}"/${PN}-1.06.03-mustbuildclient.patch
}
src_compile() {