summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-11-06 22:26:04 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-11-06 22:26:04 +0000
commit7eeb21f5603e9c836a1bab94a876ee0f96f1df2e (patch)
tree9827036d00cd7ae08165fb9b885a19dc4bd08778 /dev-libs/xapian
parentarm stable, bug #386309 (diff)
downloadgentoo-2-7eeb21f5603e9c836a1bab94a876ee0f96f1df2e.tar.gz
gentoo-2-7eeb21f5603e9c836a1bab94a876ee0f96f1df2e.tar.bz2
gentoo-2-7eeb21f5603e9c836a1bab94a876ee0f96f1df2e.zip
Economize on sse/sse2 USE flags, eliminate nosse flag
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/ChangeLog7
-rw-r--r--dev-libs/xapian/xapian-1.2.7-r3.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-libs/xapian/ChangeLog b/dev-libs/xapian/ChangeLog
index 900792c385be..337090381214 100644
--- a/dev-libs/xapian/ChangeLog
+++ b/dev-libs/xapian/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/xapian
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.65 2011/10/27 22:07:56 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.66 2011/11/06 22:26:04 blueness Exp $
+
+*xapian-1.2.7-r3 (06 Nov 2011)
+
+ 06 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +xapian-1.2.7-r3.ebuild:
+ Economize on sse/sse2 USE flags, eliminate nosse flag
*xapian-1.2.7-r2 (27 Oct 2011)
diff --git a/dev-libs/xapian/xapian-1.2.7-r3.ebuild b/dev-libs/xapian/xapian-1.2.7-r3.ebuild
new file mode 100644
index 000000000000..bce6c07e9a52
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.2.7-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.7-r3.ebuild,v 1.1 2011/11/06 22:26:04 blueness Exp $
+
+EAPI=4
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs -sse +sse2 +brass +chert +flint +inmemory +remote"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ ewarn
+ if use sse2; then
+ ewarn "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use sse; then
+ ewarn "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ ewarn "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ ewarn
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use flint || myconf="${myconf} --disable-backend-flint"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+ use remote || myconf="${myconf} --disable-backend-remote"
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
+ use doc || rm -fr "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+}
+
+src_test() {
+ emake check VALGRIND=
+}