summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2009-08-02 04:42:37 +0000
committerChris PeBenito <pebenito@gentoo.org>2009-08-02 04:42:37 +0000
commit3e726c24579a8bde5dccd2147f429f7e57722253 (patch)
tree35185f5aced4a613a3cc9e8e08c02af96a0d49a7 /dev-libs/ustr/ustr-1.0.4-r1.ebuild
parentadd drobbins to metadata per discussion with him (diff)
downloadgentoo-2-3e726c24579a8bde5dccd2147f429f7e57722253.tar.gz
gentoo-2-3e726c24579a8bde5dccd2147f429f7e57722253.tar.bz2
gentoo-2-3e726c24579a8bde5dccd2147f429f7e57722253.zip
Fix bugs #240230, #241280, and #243954.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/ustr/ustr-1.0.4-r1.ebuild')
-rw-r--r--dev-libs/ustr/ustr-1.0.4-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/ustr/ustr-1.0.4-r1.ebuild b/dev-libs/ustr/ustr-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..0171ef321df5
--- /dev/null
+++ b/dev-libs/ustr/ustr-1.0.4-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ustr/ustr-1.0.4-r1.ebuild,v 1.1 2009/08/02 04:42:37 pebenito Exp $
+
+inherit eutils
+
+DESCRIPTION="Low-overhead managed string library for C"
+HOMEPAGE="http://www.and.org/ustr"
+SRC_URI="ftp://ftp.and.org/pub/james/ustr/${PV}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD-2 MIT LGPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_compile() {
+ make CC="$(tc-getCC)" CFLAGS="${CFLAGS}" HIDE= all-shared || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" HIDE= \
+ mandir="/usr/share/man" \
+ SHRDIR="/usr/share/doc/${PF}" \
+ DOCSHRDIR="/usr/share/doc/${PF}" || die
+ dodoc ChangeLog README README-DEVELOPERS AUTHORS NEWS TODO
+}