summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 22:46:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 22:46:11 +0000
commitc0d03925bb7ede17dcd65d339c8d6ec9c227fdc1 (patch)
treebad10d5fc2668785f9ec4cfbf34ac999d1305c54 /dev-libs/syck
parentAdd prefix support, bump EAPI to 3, add prefix keywords (diff)
downloadgentoo-2-c0d03925bb7ede17dcd65d339c8d6ec9c227fdc1.tar.gz
gentoo-2-c0d03925bb7ede17dcd65d339c8d6ec9c227fdc1.tar.bz2
gentoo-2-c0d03925bb7ede17dcd65d339c8d6ec9c227fdc1.zip
Use new functionality of DISTUTILS_SETUP_FILES.
(Portage version: 2.2.0_alpha29_p17/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/syck')
-rw-r--r--dev-libs/syck/syck-0.55-r4.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/dev-libs/syck/syck-0.55-r4.ebuild b/dev-libs/syck/syck-0.55-r4.ebuild
index 11dfc8e3b4c3..bf819ece9473 100644
--- a/dev-libs/syck/syck-0.55-r4.ebuild
+++ b/dev-libs/syck/syck-0.55-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/syck-0.55-r4.ebuild,v 1.15 2011/04/10 19:54:30 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/syck-0.55-r4.ebuild,v 1.16 2011/04/12 22:46:11 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -23,6 +23,7 @@ RDEPEND="${DEPEND}"
PDEPEND="php? ( dev-php5/pecl-syck
!=dev-libs/syck-0.55-r1 )"
+DISTUTILS_SETUP_FILES=("ext/python|setup.py")
PYTHON_MODNAME="yaml2xml.py ydump.py ypath.py"
pkg_setup() {
@@ -40,22 +41,12 @@ src_configure() {
src_compile() {
emake
-
- if use python; then
- pushd ext/python > /dev/null
- distutils_src_compile
- popd > /dev/null
- fi
+ use python && distutils_src_compile
}
src_install() {
einstall
-
- if use python; then
- pushd ext/python > /dev/null
- distutils_src_install
- popd > /dev/null
- fi
+ use python && distutils_src_install
}
pkg_postinst() {