summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuval Yaari <yuval@gentoo.org>2006-08-22 15:12:29 +0000
committerYuval Yaari <yuval@gentoo.org>2006-08-22 15:12:29 +0000
commitbc4bd5cd4aba0ad5148020b68ac665268f073c95 (patch)
treec9a149bc62c586fe420b7f1810dffc7ade1f8685 /dev-libs/syck
parentPunt irqbalance from rc to it's own init script. (diff)
downloadgentoo-2-bc4bd5cd4aba0ad5148020b68ac665268f073c95.tar.gz
gentoo-2-bc4bd5cd4aba0ad5148020b68ac665268f073c95.tar.bz2
gentoo-2-bc4bd5cd4aba0ad5148020b68ac665268f073c95.zip
Revision bump; fixing bug #133929
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-libs/syck')
-rw-r--r--dev-libs/syck/ChangeLog7
-rw-r--r--dev-libs/syck/files/digest-syck-0.55-r13
-rw-r--r--dev-libs/syck/syck-0.55-r1.ebuild68
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-libs/syck/ChangeLog b/dev-libs/syck/ChangeLog
index c6bdca9fa972..58efcdd0ba45 100644
--- a/dev-libs/syck/ChangeLog
+++ b/dev-libs/syck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/syck
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/ChangeLog,v 1.7 2006/08/20 17:58:09 yuval Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/ChangeLog,v 1.8 2006/08/22 15:12:29 yuval Exp $
+
+*syck-0.55-r1 (22 Aug 2006)
+
+ 22 Aug 2006; Yuval Yaari <yuval@gentoo.org> +syck-0.55-r1.ebuild:
+ Revision bump; fixing bug #133929
20 Aug 2006; Yuval Yaari <yuval@gentoo.org> syck-0.55.ebuild:
Appending -fPIC to all archs, not just amd64 (bug #137512)
diff --git a/dev-libs/syck/files/digest-syck-0.55-r1 b/dev-libs/syck/files/digest-syck-0.55-r1
new file mode 100644
index 000000000000..36797fd04fcc
--- /dev/null
+++ b/dev-libs/syck/files/digest-syck-0.55-r1
@@ -0,0 +1,3 @@
+MD5 a57b7c46d81170b9318e2f384f77910c syck-0.55.tar.gz 354205
+RMD160 ffd26db70cf743b90cbfecfe7402c6fb8d698ee8 syck-0.55.tar.gz 354205
+SHA256 ac881945c9dfe5dd6395a5db921e8256d1d359295bb66a1acbfe49fb637c1a3a syck-0.55.tar.gz 354205
diff --git a/dev-libs/syck/syck-0.55-r1.ebuild b/dev-libs/syck/syck-0.55-r1.ebuild
new file mode 100644
index 000000000000..2c6b3ffc82e8
--- /dev/null
+++ b/dev-libs/syck/syck-0.55-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/syck-0.55-r1.ebuild,v 1.1 2006/08/22 15:12:29 yuval Exp $
+
+inherit flag-o-matic distutils ruby
+
+IUSE="php python ruby"
+DESCRIPTION="Syck is an extension for reading and writing YAML swiftly in popular scripting languages."
+HOMEPAGE="http://whytheluckystiff.net/syck/"
+SRC_URI="http://rubyforge.org/frs/download.php/4492/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="sys-libs/glibc
+ ruby? ( dev-lang/ruby
+ dev-ruby/racc
+ )
+ python? ( dev-lang/python )
+ php? ( dev-lang/php )"
+
+src_compile() {
+ append-flags -fPIC
+ econf
+ emake
+
+ if use python; then
+ pushd ext/python
+ distutils_src_compile
+ popd
+ fi
+
+ if use php; then
+ pushd ext/php
+ phpize
+ econf --with-syck
+ emake
+ popd
+ fi
+
+ if use ruby; then
+ pushd ext/ruby
+ ruby_econf
+ ruby_emake
+ popd
+ fi
+}
+
+src_install() {
+ einstall
+
+ if use python; then
+ pushd ext/python
+ distutils_src_install
+ popd
+ fi
+
+ if use ruby; then
+ pushd ext/ruby
+ ruby_einstall
+ popd
+ fi
+
+ if use php; then
+ pushd ext/php
+ einstall INSTALL_ROOT=${D}
+ popd
+ fi
+}