summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-04-11 13:12:24 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-04-11 13:12:24 +0000
commit429683ff63fc6af8c0e04fd8b00d3b8f03d1b479 (patch)
tree4cc463d35609e3ed99056740e142d82fa92b87fa /dev-libs/root/root-3.03.04-r1.ebuild
parentnew revision (diff)
downloadgentoo-2-429683ff63fc6af8c0e04fd8b00d3b8f03d1b479.tar.gz
gentoo-2-429683ff63fc6af8c0e04fd8b00d3b8f03d1b479.tar.bz2
gentoo-2-429683ff63fc6af8c0e04fd8b00d3b8f03d1b479.zip
bugfixes
Diffstat (limited to 'dev-libs/root/root-3.03.04-r1.ebuild')
-rw-r--r--dev-libs/root/root-3.03.04-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/root/root-3.03.04-r1.ebuild b/dev-libs/root/root-3.03.04-r1.ebuild
new file mode 100644
index 000000000000..329ccab1b3f5
--- /dev/null
+++ b/dev-libs/root/root-3.03.04-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Geert Bevin <gbevin@uwyn.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/root/root-3.03.04-r1.ebuild,v 1.1 2002/04/11 13:12:24 gbevin Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="An Object-Oriented Data Analysis Framework"
+SRC_URI="ftp://root.cern.ch/root/root_v3.03.04.source.tar.gz"
+HOMEPAGE="http://root.cern.ch/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=media-libs/xpm-3.4k
+ >=media-libs/freetype-2.0.9
+ opengl? ( virtual/opengl virtual/glu )
+ mysql? ( >=dev-db/mysql-3.23.49 )
+ postgres? ( >=dev-db/postgresql-7.1.3-r4 )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ use opengl && myconf="${myconf} --enable-opengl" || myconf="${myconf} --disable-opengl"
+ use mysql && myconf="${myconf} --enable-mysql" || myconf="${myconf} --disable-mysql"
+ use postgres && myconf="${myconf} --enable-pgsql" || myconf="${myconf} --disable-pgsql"
+
+ ./configure \
+ linux \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc/${P} \
+ --enable-shared \
+ --disable-rpath \
+ --enable-thread \
+ --enable-star \
+ --enable-ttf \
+ --disable-cern \
+ --disable-sapdb \
+ --disable-rfio \
+ --disable-dcache \
+ --disable-srp \
+ --disable-afs \
+ --disable-krb5 \
+ --enable-shadowpw \
+ --disable-pythia \
+ --disable-pythia6 \
+ --disable-venus \
+ --enable-soversion \
+ ${myconf} || die "./configure failed"
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodir /etc/env.d
+ echo "LDPATH=/usr/lib/root" > ${D}/etc/env.d/60root
+}