summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-31 00:43:41 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-31 00:43:41 +0000
commitc7014cee451da08917d76f0e8f12d8193886b5b0 (patch)
treeb543c9956c8e8619ea7fc1a35ef13d7d369733a9 /dev-libs/protobuf
parentVersion bump. (diff)
downloadgentoo-2-c7014cee451da08917d76f0e8f12d8193886b5b0.tar.gz
gentoo-2-c7014cee451da08917d76f0e8f12d8193886b5b0.tar.bz2
gentoo-2-c7014cee451da08917d76f0e8f12d8193886b5b0.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs/protobuf')
-rw-r--r--dev-libs/protobuf/ChangeLog7
-rw-r--r--dev-libs/protobuf/protobuf-2.6.1.ebuild126
2 files changed, 132 insertions, 1 deletions
diff --git a/dev-libs/protobuf/ChangeLog b/dev-libs/protobuf/ChangeLog
index faf59e55f09b..5255467badf5 100644
--- a/dev-libs/protobuf/ChangeLog
+++ b/dev-libs/protobuf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/protobuf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.67 2014/10/10 20:17:24 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.68 2014/10/31 00:43:41 radhermit Exp $
+
+*protobuf-2.6.1 (31 Oct 2014)
+
+ 31 Oct 2014; Tim Harder <radhermit@gentoo.org> +protobuf-2.6.1.ebuild:
+ Version bump.
10 Oct 2014; Markus Meier <maekke@gentoo.org> protobuf-2.6.0.ebuild:
add ~arm, bug #524082
diff --git a/dev-libs/protobuf/protobuf-2.6.1.ebuild b/dev-libs/protobuf/protobuf-2.6.1.ebuild
new file mode 100644
index 000000000000..1912d5d390f5
--- /dev/null
+++ b/dev-libs/protobuf/protobuf-2.6.1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.6.1.ebuild,v 1.1 2014/10/31 00:43:41 radhermit Exp $
+
+EAPI=5
+JAVA_PKG_IUSE="source"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit autotools eutils flag-o-matic distutils-r1 java-pkg-opt-2 elisp-common
+
+DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
+HOMEPAGE="http://code.google.com/p/protobuf/ https://github.com/google/protobuf/"
+SRC_URI="https://github.com/google/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0/9" # subslot = soname major version
+KEYWORDS="~amd64 ~arm -hppa ~mips -ppc -ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="emacs examples java python static-libs vim-syntax"
+
+CDEPEND="emacs? ( virtual/emacs )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${CDEPEND}
+ java? ( >=virtual/jdk-1.5 )
+ python? (
+ dev-python/google-apputils[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.5 )"
+
+src_prepare() {
+ append-cxxflags -DGOOGLE_PROTOBUF_NO_RTTI
+
+ if [[ ${CHOST} != *-darwin* ]] ; then
+ # breaks Darwin, bug #472514
+ epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch
+ eautoreconf
+ fi
+
+ if use python; then
+ cd python && distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ einfo "Compiling Python library ..."
+ pushd python >/dev/null
+ distutils-r1_src_compile
+ popd >/dev/null
+ fi
+
+ if use java; then
+ einfo "Compiling Java library ..."
+ src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
+ mkdir java/build
+ pushd java/src/main/java >/dev/null
+ ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
+ popd >/dev/null
+ jar cf ${PN}.jar -C java/build . || die "jar failed"
+ fi
+
+ if use emacs; then
+ elisp-compile "${S}"/editors/protobuf-mode.el
+ fi
+}
+
+src_test() {
+ emake check
+
+ if use python; then
+ pushd python >/dev/null
+ distutils-r1_src_test
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc CHANGES.txt CONTRIBUTORS.txt README.md
+ prune_libtool_files
+
+ if use python; then
+ pushd python >/dev/null
+ distutils-r1_src_install
+ popd >/dev/null
+ fi
+
+ if use java; then
+ java-pkg_dojar ${PN}.jar
+ use source && java-pkg_dosrc java/src/main/java/*
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins editors/proto.vim
+ insinto /usr/share/vim/vimfiles/ftdetect/
+ doins "${FILESDIR}"/proto.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} editors/protobuf-mode.el*
+ elisp-site-file-install "${FILESDIR}"/70${PN}-gentoo.el
+ fi
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}