summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-11-26 23:39:03 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-11-26 23:39:03 +0000
commit52b38d66fe2acf01e0fc09a4bff5b16805d1ab4a (patch)
tree0caedac10e6acee50903f81e47ce5343919e7098 /dev-libs/protobuf
parentFix definition of dropdown-list-selection-face. Remove old. (diff)
downloadgentoo-2-52b38d66fe2acf01e0fc09a4bff5b16805d1ab4a.tar.gz
gentoo-2-52b38d66fe2acf01e0fc09a4bff5b16805d1ab4a.tar.bz2
gentoo-2-52b38d66fe2acf01e0fc09a4bff5b16805d1ab4a.zip
Version bump.
(Portage version: 2.1.7.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/protobuf')
-rw-r--r--dev-libs/protobuf/ChangeLog8
-rw-r--r--dev-libs/protobuf/protobuf-2.2.0a.ebuild96
2 files changed, 103 insertions, 1 deletions
diff --git a/dev-libs/protobuf/ChangeLog b/dev-libs/protobuf/ChangeLog
index 25dbfda122df..244c3d074979 100644
--- a/dev-libs/protobuf/ChangeLog
+++ b/dev-libs/protobuf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/protobuf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.8 2009/08/21 17:41:18 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.9 2009/11/26 23:39:03 nelchael Exp $
+
+*protobuf-2.2.0a (26 Nov 2009)
+
+ 26 Nov 2009; Krzysiek Pawlik <nelchael@gentoo.org>
+ +protobuf-2.2.0a.ebuild:
+ Version bump.
*protobuf-2.2.0 (21 Aug 2009)
diff --git a/dev-libs/protobuf/protobuf-2.2.0a.ebuild b/dev-libs/protobuf/protobuf-2.2.0a.ebuild
new file mode 100644
index 000000000000..25e625290f1e
--- /dev/null
+++ b/dev-libs/protobuf/protobuf-2.2.0a.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.2.0a.ebuild,v 1.1 2009/11/26 23:39:03 nelchael Exp $
+
+EAPI="2"
+
+JAVA_PKG_IUSE="source"
+
+inherit eutils distutils python java-pkg-opt-2 elisp-common
+
+DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
+HOMEPAGE="http://code.google.com/p/protobuf/"
+SRC_URI="http://protobuf.googlecode.com/files/${PF}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs examples java python vim-syntax"
+
+DEPEND="${DEPEND} java? ( >=virtual/jdk-1.5 )
+ python? ( dev-python/setuptools )
+ emacs? ( virtual/emacs )"
+RDEPEND="${RDEPEND} java? ( >=virtual/jre-1.5 )
+ emacs? ( virtual/emacs )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-decoder_test_64bit_fix.patch"
+ epatch "${FILESDIR}/${P}-fix-emacs-byte-compile.patch"
+}
+
+src_compile() {
+ emake || die
+
+ if use python; then
+ cd python; distutils_src_compile; cd ..
+ fi
+
+ if use java; then
+ src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
+ mkdir java/build
+ pushd java/src/main/java
+ ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
+ popd
+ jar cf "${PN}.jar" -C java/build . || die "jar failed"
+ fi
+
+ if use emacs; then
+ elisp-compile "${S}/editors/protobuf-mode.el" || die "elisp-compile failed!"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc CHANGES.txt CONTRIBUTORS.txt README.txt
+
+ if use python; then
+ cd python; distutils_src_install; cd ..
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins editors/proto.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} editors/protobuf-mode.el* || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}/70${PN}-gentoo.el"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "doins examples failed"
+ fi
+
+ if use java; then
+ java-pkg_dojar ${PN}.jar
+ use source && java-pkg_dosrc java/src/main/java/*
+ fi
+}
+
+src_test() {
+ emake check
+
+ if use python; then
+ cd python; ${python} setup.py test || die "python test failed"
+ cd ..
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}