summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-01 18:46:28 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-01 18:46:28 +0000
commit914ff821d2c9171d59d78c830c93b4b465321ff8 (patch)
tree267b40e68e7cb52dc549ccb98698daa3b5271ad4 /dev-libs/popt
parentAdded KEYWORDS, removed old version. (diff)
downloadgentoo-2-914ff821d2c9171d59d78c830c93b4b465321ff8.tar.gz
gentoo-2-914ff821d2c9171d59d78c830c93b4b465321ff8.tar.bz2
gentoo-2-914ff821d2c9171d59d78c830c93b4b465321ff8.zip
repoman'd
Diffstat (limited to 'dev-libs/popt')
-rw-r--r--dev-libs/popt/popt-1.5.ebuild19
-rw-r--r--dev-libs/popt/popt-1.6.3.ebuild21
2 files changed, 17 insertions, 23 deletions
diff --git a/dev-libs/popt/popt-1.5.ebuild b/dev-libs/popt/popt-1.5.ebuild
index ecc54b51f4f9..17ea6ea0fa92 100644
--- a/dev-libs/popt/popt-1.5.ebuild
+++ b/dev-libs/popt/popt-1.5.ebuild
@@ -1,27 +1,24 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.5.ebuild,v 1.7 2002/08/01 11:59:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.5.ebuild,v 1.8 2002/08/01 18:46:28 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Parse Options: command line parser"
SRC_URI="ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/${P}.tar.gz"
HOMEPAGE="http://www.rpm.org"
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
+
+DEPEND="nls? ( sys-devel/gettext )"
src_compile() {
local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- $myconf || die
+ use nls || myconf="--disable-nls"
+ econf ${myconf} || die
make || die
}
diff --git a/dev-libs/popt/popt-1.6.3.ebuild b/dev-libs/popt/popt-1.6.3.ebuild
index d089aee6ba10..b3c1ff872237 100644
--- a/dev-libs/popt/popt-1.6.3.ebuild
+++ b/dev-libs/popt/popt-1.6.3.ebuild
@@ -1,27 +1,24 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.6.3.ebuild,v 1.4 2002/08/01 11:59:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.6.3.ebuild,v 1.5 2002/08/01 18:46:28 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Parse Options - Command line parser"
SRC_URI="ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/${P}.tar.gz"
HOMEPAGE="http://www.rpm.org"
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
+
+DEPEND="nls? ( sys-devel/gettext )"
src_compile() {
local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- $myconf || die
-
+ use nls || myconf="--disable-nls"
+
+ econf || die
make || die
}