summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-12-06 07:06:17 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-12-06 07:06:17 +0000
commit97f89bc2bae66badc78886039afdeb56ffd23a40 (patch)
treef3bfd0099f8db875a7dcf8029085f11e7ff7453b /dev-libs/pilot-link
parentupdated version libpcap-0.6.1 -> libpcap-0.6.2. Small whitespace issues. (diff)
downloadgentoo-2-97f89bc2bae66badc78886039afdeb56ffd23a40.tar.gz
gentoo-2-97f89bc2bae66badc78886039afdeb56ffd23a40.tar.bz2
gentoo-2-97f89bc2bae66badc78886039afdeb56ffd23a40.zip
updated, fix for UTF8 stuff
Diffstat (limited to 'dev-libs/pilot-link')
-rw-r--r--dev-libs/pilot-link/files/digest-pilot-link-0.9.6-r21
-rw-r--r--dev-libs/pilot-link/pilot-link-0.9.6-r2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/pilot-link/files/digest-pilot-link-0.9.6-r2 b/dev-libs/pilot-link/files/digest-pilot-link-0.9.6-r2
new file mode 100644
index 000000000000..b230b486880d
--- /dev/null
+++ b/dev-libs/pilot-link/files/digest-pilot-link-0.9.6-r2
@@ -0,0 +1 @@
+MD5 c8e9861317b2acfb1cb363654b309aa6 pilot-link-0.9.6.tar.gz 4415488
diff --git a/dev-libs/pilot-link/pilot-link-0.9.6-r2.ebuild b/dev-libs/pilot-link/pilot-link-0.9.6-r2.ebuild
new file mode 100644
index 000000000000..9ea39aedcf35
--- /dev/null
+++ b/dev-libs/pilot-link/pilot-link-0.9.6-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# AJ Lewis <aj@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/pilot-link-0.9.6-r2.ebuild,v 1.1 2001/12/06 07:06:17 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A suite of tools contains a series of conduits for moving
+information to and from your Palm device and your desktop or workstation
+system."
+
+SRC_URI="http://www.gnu-designs.com/pilot-link/source/${P}.tar.gz
+ http://www.eskil.org/gnome-pilot/download/tarballs/${P}.tar.gz"
+HOMEPAGE="http://www.gnu-designs.com/pilot-link/"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr/ \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --includedir=/usr/include/libpisock \
+ --with-tcl=no \
+ --with-itcl=no \
+ --with-tk=no \
+ --with-python=no \
+ --with-java=no \
+ --with-perl5=no
+ assert
+
+ # The configure-script seems to be someone broken,
+ # It says that it finds iconv in our glibc but it doesn't
+ # set the #define correctly, I'll notify one of the pilot-link
+ # hackers. // Hallski
+
+ cd ${S}/include
+ echo "#define HAVE_ICONV 1" >> pi-config.h
+
+ cd ${S}
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ includedir=${D}/usr/include/libpisock \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc COPYING COPYING.LIB ChangeLog README TODO
+ docinto sgml
+ dodoc doc/syncabs.sgml
+}