summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-10-14 03:12:38 +0000
committerNaohiro Aota <naota@gentoo.org>2011-10-14 03:12:38 +0000
commit7a7a3b15e7dfd333280eb599be983bd124388f4a (patch)
tree7cf6a41e6480b645dc67f5d4e2821ecb9e993502 /dev-libs/newt
parentAssign myself as maintainer. (diff)
downloadgentoo-2-7a7a3b15e7dfd333280eb599be983bd124388f4a.tar.gz
gentoo-2-7a7a3b15e7dfd333280eb599be983bd124388f4a.tar.bz2
gentoo-2-7a7a3b15e7dfd333280eb599be983bd124388f4a.zip
Marked as ~x86-fbsd. Add patches to build on FreeBSD
(Portage version: 2.2.0_alpha64/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/newt')
-rw-r--r--dev-libs/newt/ChangeLog6
-rw-r--r--dev-libs/newt/files/newt-0.52.12-install.patch14
-rw-r--r--dev-libs/newt/files/newt-0.52.12-whiptail.patch14
-rw-r--r--dev-libs/newt/newt-0.52.12.ebuild7
4 files changed, 38 insertions, 3 deletions
diff --git a/dev-libs/newt/ChangeLog b/dev-libs/newt/ChangeLog
index b293eb5ca557..6ea8379134a3 100644
--- a/dev-libs/newt/ChangeLog
+++ b/dev-libs/newt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/newt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.75 2011/10/14 02:53:38 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.76 2011/10/14 03:12:38 naota Exp $
+
+ 14 Oct 2011; Naohiro Aota <naota@gentoo.org> newt-0.52.12.ebuild,
+ +files/newt-0.52.12-install.patch, +files/newt-0.52.12-whiptail.patch:
+ Marked as ~x86-fbsd. Add patches to build on FreeBSD
14 Oct 2011; Naohiro Aota <naota@gentoo.org> metadata.xml:
Assign myself as maintainer.
diff --git a/dev-libs/newt/files/newt-0.52.12-install.patch b/dev-libs/newt/files/newt-0.52.12-install.patch
new file mode 100644
index 000000000000..b60f96fe6300
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.12-install.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile.in b/Makefile.in
+index 7a5f1fd..16d7fd8 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -119,7 +119,8 @@ install: $(LIBNEWT) install-sh whiptail
+ install -m 755 whiptail $(DESTDIR)/$(bindir)
+ install -m 644 whiptail.1 $(DESTDIR)/$(man1dir)
+ $(MAKE) -C po datadir=$(DESTDIR)/$(datadir) install
+- install -m 644 -D libnewt.pc $(DESTDIR)/$(pkgconfigdir)/libnewt.pc
++ install -d $(DESTDIR)/$(pkgconfigdir)
++ install -m 644 libnewt.pc $(DESTDIR)/$(pkgconfigdir)/libnewt.pc
+
+ install-sh: sharedlib $(WHIPTCLSO) _snackmodule.so
+ [ -d $(DESTDIR)/$(libdir) ] || install -m 755 -d $(DESTDIR)/$(libdir)
diff --git a/dev-libs/newt/files/newt-0.52.12-whiptail.patch b/dev-libs/newt/files/newt-0.52.12-whiptail.patch
new file mode 100644
index 000000000000..7af45cb574d6
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.12-whiptail.patch
@@ -0,0 +1,14 @@
+diff --git a/whiptail.c b/whiptail.c
+index 09eca15..ac80652 100644
+--- a/whiptail.c
++++ b/whiptail.c
+@@ -8,6 +8,9 @@
+ #include <unistd.h>
+ #include <wchar.h>
+ #include <slang.h>
++#ifdef __FreeBSD__
++# include <sys/stat.h>
++#endif
+
+ #include "nls.h"
+ #include "dialogboxes.h"
diff --git a/dev-libs/newt/newt-0.52.12.ebuild b/dev-libs/newt/newt-0.52.12.ebuild
index 0a25dbfa1223..e0cf4941f208 100644
--- a/dev-libs/newt/newt-0.52.12.ebuild
+++ b/dev-libs/newt/newt-0.52.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.12.ebuild,v 1.9 2011/03/01 01:19:47 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.12.ebuild,v 1.10 2011/10/14 03:12:38 naota Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -13,7 +13,7 @@ SRC_URI="https://fedorahosted.org/releases/n/e/newt/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="gpm tcl nls"
RDEPEND="=sys-libs/slang-2*
@@ -44,6 +44,9 @@ src_prepare() {
-e 's|instroot|DESTDIR|g' \
-e 's| make | $(MAKE) |g' \
|| die "sed Makefile.in"
+
+ epatch "${FILESDIR}"/${P}-whiptail.patch \
+ "${FILESDIR}"/${P}-install.patch
}
src_configure() {