summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-13 05:28:42 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-13 05:28:42 +0000
commit925fe12cd0dbfd58a2966dbb7a33c9625f90f6f2 (patch)
treefed72574d354b359555200fa6168d2490e52a58f /dev-libs/nettle/nettle-1.13-r1.ebuild
parentput back CREDITS into docs dir (diff)
downloadgentoo-2-925fe12cd0dbfd58a2966dbb7a33c9625f90f6f2.tar.gz
gentoo-2-925fe12cd0dbfd58a2966dbb7a33c9625f90f6f2.tar.bz2
gentoo-2-925fe12cd0dbfd58a2966dbb7a33c9625f90f6f2.zip
Fixes from PaX team to address executable stacks and PIC bugs.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'dev-libs/nettle/nettle-1.13-r1.ebuild')
-rw-r--r--dev-libs/nettle/nettle-1.13-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/nettle/nettle-1.13-r1.ebuild b/dev-libs/nettle/nettle-1.13-r1.ebuild
new file mode 100644
index 000000000000..f21660fa682e
--- /dev/null
+++ b/dev-libs/nettle/nettle-1.13-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-1.13-r1.ebuild,v 1.1 2005/10/13 05:28:41 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="cryptographic library that is designed to fit easily in any context"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/gmp
+ !<dev-libs/lsh-1.4.3-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-preprocess-asm.patch
+ epatch "${FILESDIR}"/${P}-no-exec-stack.patch
+ epatch "${FILESDIR}"/${P}-PIC.patch
+ sed -i \
+ -e '/CFLAGS/s:-ggdb3::' \
+ configure || die
+}
+
+src_compile() {
+ econf --enable-shared || die
+ emake || die
+}
+
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}