summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-06-20 16:59:37 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-06-20 16:59:37 +0000
commit0ca06a37dfc9a0d363cc15889ac2a6e66e538e5c (patch)
tree37201848926d489719bc47e31cf55e37005b4234 /dev-libs/log4c
parentRemoving tests for sparc platform (diff)
downloadgentoo-2-0ca06a37dfc9a0d363cc15889ac2a6e66e538e5c.tar.gz
gentoo-2-0ca06a37dfc9a0d363cc15889ac2a6e66e538e5c.tar.bz2
gentoo-2-0ca06a37dfc9a0d363cc15889ac2a6e66e538e5c.zip
Fixed tetex sandbox violation. General lintool clean-up.
Diffstat (limited to 'dev-libs/log4c')
-rw-r--r--dev-libs/log4c/ChangeLog9
-rw-r--r--dev-libs/log4c/files/digest-log4c-1.0.6-r11
-rw-r--r--dev-libs/log4c/log4c-1.0.6-r1.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-libs/log4c/ChangeLog b/dev-libs/log4c/ChangeLog
index 39a8c0d9efd1..7ae1664f959d 100644
--- a/dev-libs/log4c/ChangeLog
+++ b/dev-libs/log4c/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/log4c
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/ChangeLog,v 1.1 2002/05/03 01:32:35 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/ChangeLog,v 1.2 2002/06/20 16:59:37 mkennedy Exp $
+
+*log4c-1.0.6-r1 (20 Jun 2002)
+
+ 2 May 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ log4c-1.0.6-r1.ebuild, files/digest-log4c-1.0.6-r1 :
+
+ Fixed tetex sandbox violation. General lintool clean-up.
*log4c-1.0.6 (2 May 2002)
diff --git a/dev-libs/log4c/files/digest-log4c-1.0.6-r1 b/dev-libs/log4c/files/digest-log4c-1.0.6-r1
new file mode 100644
index 000000000000..6ee33c689912
--- /dev/null
+++ b/dev-libs/log4c/files/digest-log4c-1.0.6-r1
@@ -0,0 +1 @@
+MD5 8423cf1b27ede6f80525750515b65419 log4c-1.0.6.tar.gz 238798
diff --git a/dev-libs/log4c/log4c-1.0.6-r1.ebuild b/dev-libs/log4c/log4c-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..8e5d85811989
--- /dev/null
+++ b/dev-libs/log4c/log4c-1.0.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/log4c-1.0.6-r1.ebuild,v 1.1 2002/06/20 16:59:37 mkennedy Exp $
+
+LICENSE="LGPL-2.1"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Log4c is a library of C for flexible logging to files, syslog and other destinations. It is modeled after the Log for Java library (http://jakarta.apache.org/log4j/), staying as close to their API as is reasonable."
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/log4c/${P}.tar.gz"
+HOMEPAGE="http://www.cimai.com/opensource/log4c/index.html"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ >=dev-libs/expat-1.95.2
+ >=app-doc/doxygen-1.2.15
+ >=media-gfx/graphviz-1.7.15-r2
+ >=app-text/tetex-1.0.7-r9"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/expat-1.95.2"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die
+
+ addwrite "/var/lib/texmf"
+ addwrite "/usr/share/texmf"
+ addwrite "/var/cache/fonts"
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}