summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-28 17:40:54 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-28 17:40:54 +0000
commit7511a444d955b9e504463c267370a6f7c9908442 (patch)
tree236fbdd9379e7f4ccdc647a60708bd620c39b37a /dev-libs/libxslt/libxslt-1.1.28-r2.ebuild
parentDrop temporary LeechCraft masks (diff)
downloadgentoo-2-7511a444d955b9e504463c267370a6f7c9908442.tar.gz
gentoo-2-7511a444d955b9e504463c267370a6f7c9908442.tar.bz2
gentoo-2-7511a444d955b9e504463c267370a6f7c9908442.zip
Replace multilib_build_binaries with multilib_is_native_abi. The two are equivalent now, and the team has decided to use the old name as being less confusing.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs/libxslt/libxslt-1.1.28-r2.ebuild')
-rw-r--r--dev-libs/libxslt/libxslt-1.1.28-r2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/libxslt/libxslt-1.1.28-r2.ebuild b/dev-libs/libxslt/libxslt-1.1.28-r2.ebuild
index 0b40164eff56..cf1286e13c6b 100644
--- a/dev-libs/libxslt/libxslt-1.1.28-r2.ebuild
+++ b/dev-libs/libxslt/libxslt-1.1.28-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.28-r2.ebuild,v 1.1 2014/03/04 05:50:55 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.28-r2.ebuild,v 1.2 2014/04/28 17:40:54 mgorny Exp $
EAPI=5
@@ -60,14 +60,14 @@ multilib_src_configure() {
--with-html-dir="${EPREFIX}"/usr/share/doc/${PF} \
--with-html-subdir=html \
$(use_with crypt crypto) \
- $(multilib_build_binaries && use_with python || echo --without-python) \
+ $(multilib_is_native_abi && use_with python || echo --without-python) \
$(use_with debug) \
$(use_with debug mem-debug)
}
multilib_src_compile() {
default
- if use python && multilib_build_binaries; then
+ if use python && multilib_is_native_abi; then
python_copy_sources
python_foreach_impl libxslt_py_emake
fi
@@ -75,14 +75,14 @@ multilib_src_compile() {
multilib_src_test() {
default
- use python && multilib_build_binaries && python_foreach_impl libxslt_py_emake test
+ use python && multilib_is_native_abi && python_foreach_impl libxslt_py_emake test
}
multilib_src_install() {
# "default" does not work here - docs are installed by multilib_src_install_all
emake DESTDIR="${D}" install
- if use python && multilib_build_binaries; then
+ if use python && multilib_is_native_abi; then
python_foreach_impl libxslt_py_emake DESTDIR="${D}" install
python_foreach_impl python_optimize
mv "${ED}"/usr/share/doc/${PN}-python-${PV} "${ED}"/usr/share/doc/${PF}/python