summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-05-16 16:00:20 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-05-16 16:00:20 +0000
commit078f25e141a6c7c20aad5cde921c03073dfc28f3 (patch)
tree98d3fd401f63e3f66af480b5e128584fbbef3f67 /dev-libs/libsodium/libsodium-1.0.3.ebuild
parentamd64 stable (diff)
downloadgentoo-2-078f25e141a6c7c20aad5cde921c03073dfc28f3.tar.gz
gentoo-2-078f25e141a6c7c20aad5cde921c03073dfc28f3.tar.bz2
gentoo-2-078f25e141a6c7c20aad5cde921c03073dfc28f3.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-libs/libsodium/libsodium-1.0.3.ebuild')
-rw-r--r--dev-libs/libsodium/libsodium-1.0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libsodium/libsodium-1.0.3.ebuild b/dev-libs/libsodium/libsodium-1.0.3.ebuild
new file mode 100644
index 000000000000..a6b47bd8d477
--- /dev/null
+++ b/dev-libs/libsodium/libsodium-1.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsodium/libsodium-1.0.3.ebuild,v 1.1 2015/05/16 16:00:20 mrueg Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
+HOMEPAGE="https://github.com/jedisct1/libsodium"
+SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/13"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+asm minimal static-libs +urandom"
+
+src_configure() {
+ local myconf
+
+ # --disable-pie needed on x86, bug #512734
+ use x86 && myconf="${myconf} --disable-pie"
+
+ econf \
+ $(use_enable asm) \
+ $(use_enable minimal) \
+ $(use_enable !urandom blocking-random) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}