summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 20:55:03 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 20:55:03 +0000
commit541f14235634ec9414e89e8089beca533ffca899 (patch)
tree86d726368da8d5082e4e7b43278d3a356de0605c /dev-libs/librep
parent*** empty log message *** (diff)
downloadgentoo-2-541f14235634ec9414e89e8089beca533ffca899.tar.gz
gentoo-2-541f14235634ec9414e89e8089beca533ffca899.tar.bz2
gentoo-2-541f14235634ec9414e89e8089beca533ffca899.zip
*** empty log message ***
Diffstat (limited to 'dev-libs/librep')
-rw-r--r--dev-libs/librep/files/digest-librep-0.13.21
-rw-r--r--dev-libs/librep/librep-0.13.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/librep/files/digest-librep-0.13.2 b/dev-libs/librep/files/digest-librep-0.13.2
new file mode 100644
index 000000000000..d72b5b770d48
--- /dev/null
+++ b/dev-libs/librep/files/digest-librep-0.13.2
@@ -0,0 +1 @@
+MD5 b2a0590111be2bd339cc5c98806e4223 librep-0.13.2.tar.gz
diff --git a/dev-libs/librep/librep-0.13.2.ebuild b/dev-libs/librep/librep-0.13.2.ebuild
new file mode 100644
index 000000000000..ba8fadcc75ef
--- /dev/null
+++ b/dev-libs/librep/librep-0.13.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.13.2.ebuild,v 1.1 2000/11/26 20:54:17 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Share library implementing a Lisp dialect"
+SRC_URI="ftp://librep.sourceforge.net/pub/librep/"${A}
+HOMEPAGE="http://librep.sourceforge.net/"
+
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1
+ >=dev-libs/gmp-3.1"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/usr
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr aclocaldir=/${D}/usr/share/aclocal install
+ prepinfo
+ insinto /usr/include
+ doins src/rep_config.h
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO DOC
+ docinto doc
+ dodoc doc/*
+}
+
+
+