summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-05-16 07:31:07 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-05-16 07:31:07 +0000
commit8322a0a13f3ba1f19ba968f1ed460a07523ce537 (patch)
treeb7dd2d7d5671eeea3e17db59909f3af2554e1c85 /dev-libs/libredblack/libredblack-1.2.ebuild
parentnew package: Balanced Tree Searching and Sorting Library (diff)
downloadgentoo-2-8322a0a13f3ba1f19ba968f1ed460a07523ce537.tar.gz
gentoo-2-8322a0a13f3ba1f19ba968f1ed460a07523ce537.tar.bz2
gentoo-2-8322a0a13f3ba1f19ba968f1ed460a07523ce537.zip
new package: Balanced Tree Searching and Sorting Library
Diffstat (limited to 'dev-libs/libredblack/libredblack-1.2.ebuild')
-rw-r--r--dev-libs/libredblack/libredblack-1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libredblack/libredblack-1.2.ebuild b/dev-libs/libredblack/libredblack-1.2.ebuild
new file mode 100644
index 000000000000..5c7247bd2ca2
--- /dev/null
+++ b/dev-libs/libredblack/libredblack-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libredblack/libredblack-1.2.ebuild,v 1.1 2003/05/16 07:30:55 george Exp $
+
+DESCRIPTION="RedBlack Balanced Tree Searching and Sorting Library"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/glibc"
+
+#RESTRICT="nomirror"
+
+src_compile() {
+ econf --libexecdir=/usr/lib || "configure failure"
+ emake || die "compile failure"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+ rm example*.o
+ cp -a example* ${D}/usr/share/doc/${PF}
+}