summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-01-31 13:09:01 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-01-31 13:09:01 +0000
commita3028096691ad9647ada5ab14e7ec5882d01c631 (patch)
tree26c9318d27961c7b96efebdd5bca38c43c4e5924 /dev-libs/libmail
parentnet-analyzer/linkchecker: Call python_pkg_setup where necessary, #454820; fix... (diff)
downloadgentoo-2-a3028096691ad9647ada5ab14e7ec5882d01c631.tar.gz
gentoo-2-a3028096691ad9647ada5ab14e7ec5882d01c631.tar.bz2
gentoo-2-a3028096691ad9647ada5ab14e7ec5882d01c631.zip
Revision bump: port to autotools-utils eclass, reorganize CFLAGS sed into patch(fix bug #454380), add USE flags for debug and static libs building(bug #454558)
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libmail')
-rw-r--r--dev-libs/libmail/ChangeLog10
-rw-r--r--dev-libs/libmail/files/libmail-0.3-respect-cflags.patch37
-rw-r--r--dev-libs/libmail/libmail-0.3-r2.ebuild45
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-libs/libmail/ChangeLog b/dev-libs/libmail/ChangeLog
index fea2a5d6857c..2e6645e20be4 100644
--- a/dev-libs/libmail/ChangeLog
+++ b/dev-libs/libmail/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libmail
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmail/ChangeLog,v 1.6 2013/01/30 15:30:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmail/ChangeLog,v 1.7 2013/01/31 13:09:01 pinkbyte Exp $
+
+*libmail-0.3-r2 (31 Jan 2013)
+
+ 31 Jan 2013; Sergey Popov <pinkbyte@gentoo.org> +libmail-0.3-r2.ebuild,
+ +files/libmail-0.3-respect-cflags.patch:
+ Revision bump: port to autotools-utils eclass, reorganize CFLAGS sed into
+ patch(fix bug #454380), add USE flags for debug and static libs building(bug
+ #454558)
30 Jan 2013; Agostino Sarubbo <ago@gentoo.org> libmail-0.3-r1.ebuild:
Stable for x86, wrt bug #454296
diff --git a/dev-libs/libmail/files/libmail-0.3-respect-cflags.patch b/dev-libs/libmail/files/libmail-0.3-respect-cflags.patch
new file mode 100644
index 000000000000..7e22de4c7576
--- /dev/null
+++ b/dev-libs/libmail/files/libmail-0.3-respect-cflags.patch
@@ -0,0 +1,37 @@
+--- configure.ac.orig 2013-01-31 16:18:06.537834009 +0400
++++ configure.ac 2013-01-31 16:19:00.138835711 +0400
+@@ -12,7 +12,7 @@
+ AC_PROG_MAKE_SET
+ AC_PROG_LIBTOOL
+
+-CFLAGS="-D_GNU_SOURCE -Wall -Wunused -Wstrict-prototypes"
++CFLAGS="-D_GNU_SOURCE -Wall -Wunused -Wstrict-prototypes ${CFLAGS}"
+
+ use_sasl=false
+ use_apop=false
+@@ -99,7 +99,6 @@
+ ;;
+ yes)
+ AC_DEFINE(NDEBUG, [1], [Use debug functionality])
+- CFLAGS="$CFLAGS -g"
+ optimize="no"
+ ;;
+ *)
+@@ -119,7 +118,6 @@
+ ;;
+ yes)
+ AC_DEFINE(NDEBUG, [1], [Use debug functionality])
+- CFLAGS="$CFLAGS -pg -g"
+ optimize="yes"
+ ;;
+ *)
+@@ -127,9 +125,6 @@
+ ;;
+ esac
+ ])
+-if test $optimize = "yes"; then
+- CFLAGS="$CFLAGS -O2"
+-fi
+ AM_CONDITIONAL([LIBMAIL_USE_SASL], [test x$use_sasl = xtrue])
+ AM_CONDITIONAL([LIBMAIL_USE_APOP], [test x$use_apop = xtrue])
+ AM_CONDITIONAL([LIBMAIL_USE_TLS], [test x$use_tls = xtrue])
diff --git a/dev-libs/libmail/libmail-0.3-r2.ebuild b/dev-libs/libmail/libmail-0.3-r2.ebuild
new file mode 100644
index 000000000000..b728b64d10e8
--- /dev/null
+++ b/dev-libs/libmail/libmail-0.3-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmail/libmail-0.3-r2.ebuild,v 1.1 2013/01/31 13:09:01 pinkbyte Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A mail handling library"
+HOMEPAGE="http://libmail.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="apop debug gnutls profile sasl static-libs"
+
+DEPEND="gnutls? ( >=net-libs/gnutls-2 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+# Do not unset user's CFLAGS, bug #454558
+PATCHES=( "${FILESDIR}/${P}-respect-cflags.patch" )
+
+src_prepare() {
+ # Drop quotes from ACLOCAL_AMFLAGS otherwise aclocal will fail
+ # see 447760
+ sed -i -e "/ACLOCAL_AMFLAGS/s:\"::g" Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable apop)
+ $(use_enable debug)
+ $(use_enable gnutls tls)
+ $(use_enable profile)
+ $(use_enable sasl)
+ )
+ autotools-utils_src_configure
+}