summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-05-07 20:55:30 +0000
committerChristoph Mende <angelos@gentoo.org>2011-05-07 20:55:30 +0000
commit11c2544d40c9305979c7777c5e2fa5fdfc4beddb (patch)
tree107039408ad03752befdfce7df2cdd6206b17c48 /dev-libs/libindicator
parentFix JPL handling of long values (diff)
downloadgentoo-2-11c2544d40c9305979c7777c5e2fa5fdfc4beddb.tar.gz
gentoo-2-11c2544d40c9305979c7777c5e2fa5fdfc4beddb.tar.bz2
gentoo-2-11c2544d40c9305979c7777c5e2fa5fdfc4beddb.zip
Version bump
(Portage version: 2.2.0_alpha31/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libindicator')
-rw-r--r--dev-libs/libindicator/ChangeLog10
-rw-r--r--dev-libs/libindicator/libindicator-0.3.22.ebuild43
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-libs/libindicator/ChangeLog b/dev-libs/libindicator/ChangeLog
index 08c373e1a7aa..da7d263f8971 100644
--- a/dev-libs/libindicator/ChangeLog
+++ b/dev-libs/libindicator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libindicator
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicator/ChangeLog,v 1.5 2010/09/18 18:53:14 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicator/ChangeLog,v 1.6 2011/05/07 20:55:30 angelos Exp $
+
+*libindicator-0.3.22 (07 May 2011)
+
+ 07 May 2011; Christoph Mende <angelos@gentoo.org>
+ +libindicator-0.3.22.ebuild:
+ Version bump
*libindicator-0.3.13 (18 Sep 2010)
diff --git a/dev-libs/libindicator/libindicator-0.3.22.ebuild b/dev-libs/libindicator/libindicator-0.3.22.ebuild
new file mode 100644
index 000000000000..709222d67382
--- /dev/null
+++ b/dev-libs/libindicator/libindicator-0.3.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicator/libindicator-0.3.22.ebuild,v 1.1 2011/05/07 20:55:30 angelos Exp $
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="A set of symbols and convience functions that all indicators would like to use"
+HOMEPAGE="http://launchpad.net/libindicator/"
+SRC_URI="http://launchpad.net/${PN}/0.3/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.18:2
+ >=dev-libs/glib-2.22:2
+ >=dev-libs/dbus-glib-0.76
+ !<gnome-extra/indicator-applet-0.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e 's:-Werror::' \
+ {libindicator,tests,tools}/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # TODO gtk+3 support
+ econf \
+ --disable-static \
+ --with-gtk=2
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 install
+ dodoc AUTHORS ChangeLog
+ find "${ED}" -type f -name "*.la" -exec rm -rf {} + || die
+}