summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-07-05 19:25:41 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-07-05 19:25:41 +0000
commitbc773fa10b399abd742d403c5877173927252269 (patch)
tree90193d9f3dd5522ecdd1dc0b9c07bd84eb52d0fe /dev-libs/libhome
parentremove file components/WeaveCrypto.so compiled for ARM, fix bug 276323 (diff)
downloadgentoo-2-bc773fa10b399abd742d403c5877173927252269.tar.gz
gentoo-2-bc773fa10b399abd742d403c5877173927252269.tar.bz2
gentoo-2-bc773fa10b399abd742d403c5877173927252269.zip
version bump, fixes #265588 and maybe #234538
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libhome')
-rw-r--r--dev-libs/libhome/ChangeLog10
-rw-r--r--dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch12
-rw-r--r--dev-libs/libhome/libhome-0.10.2.ebuild49
3 files changed, 69 insertions, 2 deletions
diff --git a/dev-libs/libhome/ChangeLog b/dev-libs/libhome/ChangeLog
index b2488627695c..0b480d01d59d 100644
--- a/dev-libs/libhome/ChangeLog
+++ b/dev-libs/libhome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libhome
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/ChangeLog,v 1.8 2008/06/10 09:29:48 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/ChangeLog,v 1.9 2009/07/05 19:25:39 hollow Exp $
+
+*libhome-0.10.2 (05 Jul 2009)
+
+ 05 Jul 2009; Benedikt Böhm <hollow@gentoo.org>
+ +files/libhome-0.10.2-ldap_deprecated.patch, +libhome-0.10.2.ebuild:
+ version bump, fixes #265588 and maybe #234538
10 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
-files/libhome-0.10.1-fixlt.patch, libhome-0.10.1.ebuild:
diff --git a/dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch b/dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch
new file mode 100644
index 000000000000..a96645176c13
--- /dev/null
+++ b/dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch
@@ -0,0 +1,12 @@
+Index: libhome-0.10.2/hldap.c
+===================================================================
+--- libhome-0.10.2.orig/hldap.c
++++ libhome-0.10.2/hldap.c
+@@ -27,6 +27,7 @@ static char const rcsid[] UNUSED =
+ "$Id: libhome-0.10.2-ldap_deprecated.patch,v 1.1 2009/07/05 19:25:41 hollow Exp $";
+
+ #define passwd system_passwd
++#define LDAP_DEPRECATED 1
+ #include <lber.h> /* for openldap 1.x */
+ #include <ldap.h>
+ #include <errno.h>
diff --git a/dev-libs/libhome/libhome-0.10.2.ebuild b/dev-libs/libhome/libhome-0.10.2.ebuild
new file mode 100644
index 000000000000..1abbbbd63aa0
--- /dev/null
+++ b/dev-libs/libhome/libhome-0.10.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/libhome-0.10.2.ebuild,v 1.1 2009/07/05 19:25:39 hollow Exp $
+
+inherit autotools db-use eutils
+
+DESCRIPTION="libhome is a library providing a getpwnam() emulation"
+HOMEPAGE="http://pll.sourceforge.net"
+SRC_URI="mirror://sourceforge/pll/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb ldap mysql pam postgres"
+
+DEPEND="berkdb? ( =sys-libs/db-4* )
+ ldap? ( net-nds/openldap )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( virtual/postgresql-server )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f aclocal.m4
+ epatch "${FILESDIR}"/${PN}-0.10.1-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-0.10.2-ldap_deprecated.patch
+
+ # bug 225579
+ sed -i -e 's:\<VERSION\>:__PKG_VERSION:' configure.in
+
+ eautoreconf
+}
+
+src_compile() {
+ econf --without-db3 \
+ $(use_with berkdb db4 $(db_includedir)) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with pam) \
+ $(use_with postgres pgsql) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}