summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-10 02:06:51 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-10 02:06:51 +0000
commite24ddc3743146d6f73831afe41bc0874c7750ab2 (patch)
tree7040f4c73602d0bd0d4da2377d5be5fe40878f7d /dev-libs/libhoard/libhoard-2.1.0.ebuild
parentnew package. Fixes #3447 (diff)
downloadgentoo-2-e24ddc3743146d6f73831afe41bc0874c7750ab2.tar.gz
gentoo-2-e24ddc3743146d6f73831afe41bc0874c7750ab2.tar.bz2
gentoo-2-e24ddc3743146d6f73831afe41bc0874c7750ab2.zip
New package. Fixes #3445
Diffstat (limited to 'dev-libs/libhoard/libhoard-2.1.0.ebuild')
-rw-r--r--dev-libs/libhoard/libhoard-2.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/libhoard/libhoard-2.1.0.ebuild b/dev-libs/libhoard/libhoard-2.1.0.ebuild
new file mode 100644
index 000000000000..723fa48f146b
--- /dev/null
+++ b/dev-libs/libhoard/libhoard-2.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhoard/libhoard-2.1.0.ebuild,v 1.1 2002/06/10 02:06:51 rphillips Exp $
+
+DESCRIPTION="A fast, scalable and memory-efficient allocator for multiprocessors"
+HOMEPAGE="http://www.hoard.org/"
+LICENSE="LGPL-2.1"
+DEPEND="virtual/glibc"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+src_compile() {
+ # update libtool
+ libtoolize --copy --force
+
+ # enable the GNU extensions
+ export CPPFLAGS=-D_GNU_SOURCE
+
+ econf || die "./configure failed"
+ emake || die "compilation failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc NEWS README docs/*
+}
+