summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-03-08 10:57:22 +0000
committerPacho Ramos <pacho@gentoo.org>2014-03-08 10:57:22 +0000
commit362ecb1d6bd90fbf1185703f8a21e5c8f3c5a0a9 (patch)
tree48f38bca3d16985939c65d66fc5469bbc1f2c73b /dev-libs/libgee
parentVersion bump (diff)
downloadgentoo-2-362ecb1d6bd90fbf1185703f8a21e5c8f3c5a0a9.tar.gz
gentoo-2-362ecb1d6bd90fbf1185703f8a21e5c8f3c5a0a9.tar.bz2
gentoo-2-362ecb1d6bd90fbf1185703f8a21e5c8f3c5a0a9.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/libgee')
-rw-r--r--dev-libs/libgee/ChangeLog7
-rw-r--r--dev-libs/libgee/libgee-0.12.1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-libs/libgee/ChangeLog b/dev-libs/libgee/ChangeLog
index 2094adc8edfd..5aebb60903f5 100644
--- a/dev-libs/libgee/ChangeLog
+++ b/dev-libs/libgee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/ChangeLog,v 1.83 2014/02/22 21:16:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/ChangeLog,v 1.84 2014/03/08 10:57:22 pacho Exp $
+
+*libgee-0.12.1 (08 Mar 2014)
+
+ 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> +libgee-0.12.1.ebuild:
+ Version bump
22 Feb 2014; Pacho Ramos <pacho@gentoo.org> libgee-0.6.8.ebuild:
Fix wrong commit, bug 502160
diff --git a/dev-libs/libgee/libgee-0.12.1.ebuild b/dev-libs/libgee/libgee-0.12.1.ebuild
new file mode 100644
index 000000000000..c33126c1d85c
--- /dev/null
+++ b/dev-libs/libgee/libgee-0.12.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/libgee-0.12.1.ebuild,v 1.1 2014/03/08 10:57:22 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GObject-based interfaces and classes for commonly used data structures"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libgee"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.8"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="+introspection"
+
+# FIXME: add doc support, requires valadoc
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog* MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ $(use_enable introspection)
+ VALAC="$(type -P false)"
+}