summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 06:40:45 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 06:40:45 +0000
commit815282e1faa08a8dd4c8fbce603c95c85b3d50f7 (patch)
tree07bb1644b1ab4e65d70919e6441467d0492f240f /dev-libs/libf2c
parentOld version of zope depending on python-2.3 left the tree. Bug #222037 (diff)
downloadgentoo-2-815282e1faa08a8dd4c8fbce603c95c85b3d50f7.tar.gz
gentoo-2-815282e1faa08a8dd4c8fbce603c95c85b3d50f7.tar.bz2
gentoo-2-815282e1faa08a8dd4c8fbce603c95c85b3d50f7.zip
Bump to latest upstream code. (#164397) Provide SONAME in libf2c.so. Also links libf2c with libm so we don't get any undefined symbols.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
Diffstat (limited to 'dev-libs/libf2c')
-rw-r--r--dev-libs/libf2c/ChangeLog12
-rw-r--r--dev-libs/libf2c/files/20070912-link-shared-libf2c-correctly.patch11
-rw-r--r--dev-libs/libf2c/libf2c-20070912.ebuild54
3 files changed, 75 insertions, 2 deletions
diff --git a/dev-libs/libf2c/ChangeLog b/dev-libs/libf2c/ChangeLog
index e657ebac41ee..41bf559ca7b5 100644
--- a/dev-libs/libf2c/ChangeLog
+++ b/dev-libs/libf2c/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libf2c
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libf2c/ChangeLog,v 1.23 2007/12/25 14:15:53 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libf2c/ChangeLog,v 1.24 2008/07/08 06:40:44 dberkholz Exp $
+
+*libf2c-20070912 (08 Jul 2008)
+
+ 08 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/20070912-link-shared-libf2c-correctly.patch,
+ +libf2c-20070912.ebuild:
+ Bump to latest upstream code. (#164397) Provide SONAME in libf2c.so. Also
+ links libf2c with libm so we don't get any undefined symbols.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing kugelfang from metadata.xml as per #46972.
diff --git a/dev-libs/libf2c/files/20070912-link-shared-libf2c-correctly.patch b/dev-libs/libf2c/files/20070912-link-shared-libf2c-correctly.patch
new file mode 100644
index 000000000000..de85b6dbb471
--- /dev/null
+++ b/dev-libs/libf2c/files/20070912-link-shared-libf2c-correctly.patch
@@ -0,0 +1,11 @@
+--- makefile.u.orig 2008-07-07 23:27:41.000000000 -0700
++++ makefile.u 2008-07-07 23:28:39.000000000 -0700
+@@ -82,7 +82,7 @@
+ ## of "cc -shared".
+
+ libf2c.so: $(OFILES)
+- cc -shared -o libf2c.so $(OFILES)
++ $(CC) -shared -lm -o libf2c.so $(OFILES)
+
+ ### If your system lacks ranlib, you don't need it; see README.
+
diff --git a/dev-libs/libf2c/libf2c-20070912.ebuild b/dev-libs/libf2c/libf2c-20070912.ebuild
new file mode 100644
index 000000000000..787c3e1b9f32
--- /dev/null
+++ b/dev-libs/libf2c/libf2c-20070912.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libf2c/libf2c-20070912.ebuild,v 1.1 2008/07/08 06:40:44 dberkholz Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Library that converts FORTRAN to C source."
+HOMEPAGE="ftp://ftp.netlib.org/f2c/index.html"
+#SRC_URI="ftp://ftp.netlib.org/f2c/${PN}.zip"
+SRC_URI="http://dev.gentoo.org/~dberkholz/distfiles/${P}.zip
+ mirror://gentoo/${P}.zip"
+
+LICENSE="libf2c"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/libc
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/20051004-add-ofiles-dep.patch
+ epatch ${FILESDIR}/20070912-link-shared-libf2c-correctly.patch
+}
+
+src_compile() {
+ emake \
+ -f makefile.u \
+ all \
+ CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ || die "all failed"
+
+ # Clean up files so we can recompile PIC for the shared lib
+ rm *.o || die "clean failed"
+
+ emake \
+ -f makefile.u \
+ libf2c.so \
+ CFLAGS="${CFLAGS} -fPIC" \
+ CC="$(tc-getCC)" \
+ || die "libf2c.so failed"
+}
+
+src_install () {
+ dolib.a libf2c.a || die "dolib.a failed"
+ dolib libf2c.so || die "dolib failed"
+ insinto /usr/include
+ doins f2c.h || die "f2c.h install failed"
+ dodoc README Notice || die "doc install failed"
+}