summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-03-07 13:27:06 +0000
committerThomas Kahle <tomka@gentoo.org>2013-03-07 13:27:06 +0000
commitc07931f0ba600744990cd95da81ce2ee09fdf220 (patch)
tree3d97f8054bf5626b6dd9b69f99ae78becd917d61 /dev-libs/libev
parentRefix metadata for proxy maintainership (diff)
downloadgentoo-2-c07931f0ba600744990cd95da81ce2ee09fdf220.tar.gz
gentoo-2-c07931f0ba600744990cd95da81ce2ee09fdf220.tar.bz2
gentoo-2-c07931f0ba600744990cd95da81ce2ee09fdf220.zip
bump to 4.15 (proxy commit)
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'dev-libs/libev')
-rw-r--r--dev-libs/libev/ChangeLog7
-rw-r--r--dev-libs/libev/libev-4.15.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-libs/libev/ChangeLog b/dev-libs/libev/ChangeLog
index f4725d24f9e7..71c8b27808de 100644
--- a/dev-libs/libev/ChangeLog
+++ b/dev-libs/libev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libev
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/ChangeLog,v 1.52 2013/03/06 10:27:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/ChangeLog,v 1.53 2013/03/07 13:27:06 tomka Exp $
+
+*libev-4.15 (07 Mar 2013)
+
+ 07 Mar 2013; Thomas Kahle <tomka@gentoo.org> +libev-4.15.ebuild:
+ bump to 4.15 (proxy commit)
06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> libev-4.11-r1.ebuild:
Stable for sh, wrt bug #458712
diff --git a/dev-libs/libev/libev-4.15.ebuild b/dev-libs/libev/libev-4.15.ebuild
new file mode 100644
index 000000000000..98e2d76c2106
--- /dev/null
+++ b/dev-libs/libev/libev-4.15.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/libev-4.15.ebuild,v 1.1 2013/03/07 13:27:06 tomka Exp $
+
+EAPI=5
+
+inherit autotools eutils multilib
+
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${P}.tar.gz
+ http://dist.schmorp.de/libev/Attic/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="elibc_glibc static-libs"
+
+# Bug #283558
+DEPEND="elibc_glibc? ( >=sys-libs/glibc-2.9_p20081201 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( Changes README )
+
+src_prepare() {
+ sed -i -e "/^include_HEADERS/s/ event.h//" Makefile.am || die
+
+ # bug #411847
+ epatch "${FILESDIR}/${PN}-pc.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libev.so.3.0.0
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libev.so.3.0.0
+}