summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-02-27 11:52:54 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-02-27 11:52:54 +0000
commit41470a3568241aec740b9df6ca80ed34674dc8c5 (patch)
tree26ab912565280c79b5b3965b05b91f7d649475b9 /dev-libs/libdivecomputer
parentversion bump, drop old (diff)
downloadgentoo-2-41470a3568241aec740b9df6ca80ed34674dc8c5.tar.gz
gentoo-2-41470a3568241aec740b9df6ca80ed34674dc8c5.tar.bz2
gentoo-2-41470a3568241aec740b9df6ca80ed34674dc8c5.zip
Version bump, add new proxied maintainer, bug #500568
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs/libdivecomputer')
-rw-r--r--dev-libs/libdivecomputer/ChangeLog8
-rw-r--r--dev-libs/libdivecomputer/libdivecomputer-0.4.2.ebuild75
-rw-r--r--dev-libs/libdivecomputer/metadata.xml29
3 files changed, 99 insertions, 13 deletions
diff --git a/dev-libs/libdivecomputer/ChangeLog b/dev-libs/libdivecomputer/ChangeLog
index cc223bb24382..bae8cdc7cf6b 100644
--- a/dev-libs/libdivecomputer/ChangeLog
+++ b/dev-libs/libdivecomputer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libdivecomputer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivecomputer/ChangeLog,v 1.11 2014/02/27 08:38:43 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivecomputer/ChangeLog,v 1.12 2014/02/27 11:52:54 pinkbyte Exp $
+
+*libdivecomputer-0.4.2 (27 Feb 2014)
+
+ 27 Feb 2014; Sergey Popov <pinkbyte@gentoo.org>
+ +libdivecomputer-0.4.2.ebuild, metadata.xml:
+ Version bump, add new proxied maintainer, bug #500568
27 Feb 2014; Sergey Popov <pinkbyte@gentoo.org> libdivecomputer-0.4.1.ebuild,
libdivecomputer-9999.ebuild:
diff --git a/dev-libs/libdivecomputer/libdivecomputer-0.4.2.ebuild b/dev-libs/libdivecomputer/libdivecomputer-0.4.2.ebuild
new file mode 100644
index 000000000000..dfed4dd9a778
--- /dev/null
+++ b/dev-libs/libdivecomputer/libdivecomputer-0.4.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivecomputer/libdivecomputer-0.4.2.ebuild,v 1.1 2014/02/27 11:52:54 pinkbyte Exp $
+
+EAPI="5"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://libdivecomputer.git.sourceforge.net/gitroot/libdivecomputer/libdivecomputer"
+ GIT_ECLASS="git-2"
+ AUTOTOOLIZE=yes
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit eutils autotools-utils ${GIT_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.divesoftware.org/libdc/releases/${P}.tar.gz"
+fi
+
+DESCRIPTION="Library for communication with dive computers from various manufacturers."
+HOMEPAGE="http://www.divesoftware.org/libdc"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+IUSE="usb +static-libs -tools"
+
+RDEPEND="usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if [[ -n ${AUTOTOOLIZE} ]]; then
+ autotools-utils_src_prepare
+ else
+ epatch_user
+ fi
+}
+
+src_configure() {
+ autotools-utils_src_configure
+
+ if ! use tools ; then
+ sed -i 's|examples||' Makefile || die "sed failed"
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use tools ; then
+ einfo "prefixing tools with 'dctool_'"
+ pushd "${D}/usr/bin/"
+ for file in * ; do
+ mv "${file}" "dctool_${file}" || die "prefixing tools failed"
+ done
+ popd
+ fi
+}
+
+pkg_postinst() {
+ if use tools ; then
+ elog "The 'tools' USE flag has been enabled,"
+ elog "to avoid file collisions, all ${PN}"
+ elog "related tools have been prefixed with 'dctool_'"
+ fi
+}
diff --git a/dev-libs/libdivecomputer/metadata.xml b/dev-libs/libdivecomputer/metadata.xml
index d8e9eff4feba..567d2b150e41 100644
--- a/dev-libs/libdivecomputer/metadata.xml
+++ b/dev-libs/libdivecomputer/metadata.xml
@@ -1,16 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>aaron@flappyport.com</email>
- <name>Aaron Bauman</name>
- <description>Proxied maintainer. Assign bugs to him.</description>
- </maintainer>
- <herd>proxy-maintainers</herd>
- <longdescription lang="en">
- Library for communication with dive computers from various manufacturers.
- </longdescription>
- <use>
- <flag name="tools">Install tools that can be used to test the library.</flag>
- </use>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>me@bearsh.org</email>
+ <name>Martin Gysel</name>
+ <description>Proxied maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <maintainer>
+ <email>aaron@flappyport.com</email>
+ <name>Aaron Bauman</name>
+ <description>Proxied maintainer. CC him on bugs.</description>
+ </maintainer>
+ <longdescription lang="en">
+ Library for communication with dive computers from various manufacturers.
+ </longdescription>
+ <use>
+ <flag name="tools">Install tools that can be used to test the library.</flag>
+ </use>
</pkgmetadata>