summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-13 18:44:59 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-13 18:44:59 +0000
commitebbcbc0c382d0a46dec30e1594090f2eedbff5e1 (patch)
treee1be121b85c47cbb736b128fda546f15d870338f /dev-libs/libburn
parentAdded patch for plplot-5.9 support (fixes bug #217361). (diff)
downloadgentoo-2-ebbcbc0c382d0a46dec30e1594090f2eedbff5e1.tar.gz
gentoo-2-ebbcbc0c382d0a46dec30e1594090f2eedbff5e1.tar.bz2
gentoo-2-ebbcbc0c382d0a46dec30e1594090f2eedbff5e1.zip
Move pkgconfig from RDEPEND to DEPEND only, and remove unused versions.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'dev-libs/libburn')
-rw-r--r--dev-libs/libburn/ChangeLog6
-rw-r--r--dev-libs/libburn/libburn-0.3.6.ebuild17
-rw-r--r--dev-libs/libburn/libburn-0.4.0-r1.ebuild25
-rw-r--r--dev-libs/libburn/libburn-0.4.0.ebuild22
-rw-r--r--dev-libs/libburn/libburn-0.4.2.ebuild12
5 files changed, 20 insertions, 62 deletions
diff --git a/dev-libs/libburn/ChangeLog b/dev-libs/libburn/ChangeLog
index b94df105467a..7e964b97131c 100644
--- a/dev-libs/libburn/ChangeLog
+++ b/dev-libs/libburn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libburn
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/ChangeLog,v 1.17 2008/02/25 01:36:50 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/ChangeLog,v 1.18 2008/04/13 18:44:59 drac Exp $
+
+ 13 Apr 2008; Samuli Suominen <drac@gentoo.org> libburn-0.3.6.ebuild,
+ -libburn-0.4.0.ebuild, -libburn-0.4.0-r1.ebuild, libburn-0.4.2.ebuild:
+ Move pkgconfig from RDEPEND to DEPEND only, and remove unused versions.
*libburn-0.4.2 (25 Feb 2008)
diff --git a/dev-libs/libburn/libburn-0.3.6.ebuild b/dev-libs/libburn/libburn-0.3.6.ebuild
index 06ca644e3467..8357100d3e60 100644
--- a/dev-libs/libburn/libburn-0.3.6.ebuild
+++ b/dev-libs/libburn/libburn-0.3.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/libburn-0.3.6.ebuild,v 1.4 2007/07/30 16:36:51 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/libburn-0.3.6.ebuild,v 1.5 2008/04/13 18:44:59 drac Exp $
DESCRIPTION="Libburn is an open-source library for reading, mastering and writing optical discs."
-HOMEPAGE="http://libburnia.pykix.org/"
+HOMEPAGE="http://libburnia.pykix.org"
SRC_URI="http://libburnia-download.pykix.org/releases/${P}.tar.gz"
LICENSE="GPL-2"
@@ -11,12 +11,11 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="virtual/libc"
-
-RDEPEND="${DEPEND}
- >=dev-util/pkgconfig-0.12"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS CONTRIBUTORS README ChangeLog NEWS doc/comments
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS CONTRIBUTORS ChangeLog NEWS README doc/comments
}
diff --git a/dev-libs/libburn/libburn-0.4.0-r1.ebuild b/dev-libs/libburn/libburn-0.4.0-r1.ebuild
deleted file mode 100644
index 8651f575a084..000000000000
--- a/dev-libs/libburn/libburn-0.4.0-r1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/libburn-0.4.0-r1.ebuild,v 1.1 2008/01/05 17:14:28 drac Exp $
-
-inherit multilib
-
-DESCRIPTION="Libburn is an open-source library for reading, mastering and writing optical discs."
-HOMEPAGE="http://libburnia.pykix.org/"
-SRC_URI="http://libburnia-download.pykix.org/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="virtual/libc"
-
-RDEPEND="${DEPEND}
- >=dev-util/pkgconfig-0.12"
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS CONTRIBUTORS README ChangeLog NEWS doc/comments
- dosym libburn-5.pc /usr/$(get_libdir)/pkgconfig/libburn-1.pc
-}
diff --git a/dev-libs/libburn/libburn-0.4.0.ebuild b/dev-libs/libburn/libburn-0.4.0.ebuild
deleted file mode 100644
index eefed6243da1..000000000000
--- a/dev-libs/libburn/libburn-0.4.0.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/libburn-0.4.0.ebuild,v 1.1 2007/12/16 22:35:57 pylon Exp $
-
-DESCRIPTION="Libburn is an open-source library for reading, mastering and writing optical discs."
-HOMEPAGE="http://libburnia.pykix.org/"
-SRC_URI="http://libburnia-download.pykix.org/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="virtual/libc"
-
-RDEPEND="${DEPEND}
- >=dev-util/pkgconfig-0.12"
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS CONTRIBUTORS README ChangeLog NEWS doc/comments
-}
diff --git a/dev-libs/libburn/libburn-0.4.2.ebuild b/dev-libs/libburn/libburn-0.4.2.ebuild
index 2ad0872d4e8a..3c14cde33894 100644
--- a/dev-libs/libburn/libburn-0.4.2.ebuild
+++ b/dev-libs/libburn/libburn-0.4.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/libburn-0.4.2.ebuild,v 1.1 2008/02/25 01:36:50 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/libburn-0.4.2.ebuild,v 1.2 2008/04/13 18:44:59 drac Exp $
DESCRIPTION="Libburn is an open-source library for reading, mastering and writing optical discs."
-HOMEPAGE="http://libburnia-project.org/"
+HOMEPAGE="http://libburnia-project.org"
SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
LICENSE="GPL-2"
@@ -11,9 +11,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE=""
-RDEPEND=">=dev-util/pkgconfig-0.12"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS CONTRIBUTORS README ChangeLog NEWS doc/comments
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog CONTRIBUTORS NEWS README doc/comments
}