summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-05-05 13:22:41 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-05-05 13:22:41 +0000
commitda8243923aa7a8167b679ba62e8f3f25cc82f672 (patch)
tree03c85e3d367d3a22775003031b74628787c07bee /dev-libs/libRocket
parentMarked ~hppa (bug #468582). (diff)
downloadgentoo-2-da8243923aa7a8167b679ba62e8f3f25cc82f672.tar.gz
gentoo-2-da8243923aa7a8167b679ba62e8f3f25cc82f672.tar.bz2
gentoo-2-da8243923aa7a8167b679ba62e8f3f25cc82f672.zip
add multilib support, update live ebuild
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-libs/libRocket')
-rw-r--r--dev-libs/libRocket/ChangeLog8
-rw-r--r--dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild95
-rw-r--r--dev-libs/libRocket/libRocket-9999.ebuild85
3 files changed, 154 insertions, 34 deletions
diff --git a/dev-libs/libRocket/ChangeLog b/dev-libs/libRocket/ChangeLog
index 81136a33955e..24b9b7d8fb59 100644
--- a/dev-libs/libRocket/ChangeLog
+++ b/dev-libs/libRocket/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libRocket
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/ChangeLog,v 1.2 2013/01/18 22:31:09 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/ChangeLog,v 1.3 2013/05/05 13:22:41 hasufell Exp $
+
+*libRocket-1.2.1_p20130110-r1 (05 May 2013)
+
+ 05 May 2013; Julian Ospald <hasufell@gentoo.org>
+ +libRocket-1.2.1_p20130110-r1.ebuild, libRocket-9999.ebuild:
+ add multilib support, update live ebuild
18 Jan 2013; Julian Ospald <hasufell@gentoo.org> libRocket-1.2.1.ebuild,
libRocket-1.2.1_p20130110.ebuild, libRocket-9999.ebuild:
diff --git a/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild b/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
new file mode 100644
index 000000000000..01fd33069bb7
--- /dev/null
+++ b/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild,v 1.1 2013/05/05 13:22:41 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+inherit cmake-utils eutils python-r1 multilib-minimal
+
+DESCRIPTION="A HTML/CSS User Interface library"
+HOMEPAGE="http://librocket.com/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python samples"
+
+RDEPEND="
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/boost[${PYTHON_USEDEP}]
+ )
+ samples? (
+ virtual/opengl
+ x11-libs/libXext
+ x11-libs/libX11
+ )"
+DEPEND="${RDEPEND}"
+
+DOCS=( changelog.txt readme.md )
+
+python_BUILD_DIR=${WORKDIR}/${P}_build_python
+CMAKE_USE_DIR="${S}"/Build
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PYTHON_BINDINGS=OFF
+ -DSAMPLES_DIR=/usr/share/${PN}/samples
+ )
+
+ if [[ ${ABI} == ${DEFAULT_ABI} ]] ; then
+ mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
+ else
+ mycmakeargs+=( -DBUILD_SAMPLES=OFF )
+ fi
+
+ cmake-utils_src_configure
+
+ if [[ ${ABI} == ${DEFAULT_ABI} ]] ; then
+ if use python ; then
+ cfgpybind() {
+ local mycmakeargs=(
+ -DBUILD_PYTHON_BINDINGS=ON
+ -DCMAKE_SKIP_RPATH=YES
+ )
+ BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
+ }
+ einfo "configuring python binding"
+ python_foreach_impl cfgpybind
+ fi
+ fi
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+
+ if [[ ${ABI} == ${DEFAULT_ABI} ]] ; then
+ if use python ; then
+ buildpybind() {
+ cp "${S}-${ABI}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
+ BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
+ }
+ einfo "compiling python binding"
+ python_foreach_impl buildpybind
+ fi
+ fi
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+
+ if [[ ${ABI} == ${DEFAULT_ABI} ]] ; then
+ if use python ; then
+ instpybind() {
+ python_domodule "${S}"/bin/rocket.py
+ exeinto "$(python_get_sitedir)"
+ doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
+ }
+ einfo "installing python binding"
+ python_foreach_impl instpybind
+ fi
+ fi
+}
diff --git a/dev-libs/libRocket/libRocket-9999.ebuild b/dev-libs/libRocket/libRocket-9999.ebuild
index adefe0822a4c..e0dfe57aaae6 100644
--- a/dev-libs/libRocket/libRocket-9999.ebuild
+++ b/dev-libs/libRocket/libRocket-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-9999.ebuild,v 1.2 2013/01/18 22:31:09 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-9999.ebuild,v 1.3 2013/05/05 13:22:41 hasufell Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-inherit cmake-utils git-2 python-r1
+inherit cmake-utils git-2 python-r1 multilib-minimal
DESCRIPTION="A HTML/CSS User Interface library"
HOMEPAGE="http://librocket.com/"
@@ -17,61 +17,80 @@ SLOT="0"
KEYWORDS=""
IUSE="python samples"
-RDEPEND="media-libs/freetype
+RDEPEND="
+ media-libs/freetype[${MULTILIB_USEDEP}]
python? (
${PYTHON_DEPS}
- dev-libs/boost[python,${PYTHON_USEDEP}]
+ dev-libs/boost[${PYTHON_USEDEP}]
+ )
+ samples? (
+ virtual/opengl
+ x11-libs/libXext
+ x11-libs/libX11
)"
DEPEND="${RDEPEND}"
+DOCS=( changelog.txt readme.md )
+
python_BUILD_DIR=${WORKDIR}/${P}_build_python
CMAKE_USE_DIR="${S}"/Build
-src_configure() {
+multilib_src_configure() {
local mycmakeargs=(
-DBUILD_PYTHON_BINDINGS=OFF
- $(cmake-utils_use_build samples SAMPLES)
-DSAMPLES_DIR=/usr/share/${PN}/samples
)
+ if [[ ${ABI} == ${DEFAULT_ABI} ]] ; then
+ mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
+ else
+ mycmakeargs+=( -DBUILD_SAMPLES=OFF )
+ fi
+
cmake-utils_src_configure
- if use python ; then
- cfgpybind() {
- local mycmakeargs=(
- -DBUILD_PYTHON_BINDINGS=ON
- -DCMAKE_SKIP_RPATH=YES
- )
- BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
- }
- einfo "configuring python binding"
- python_foreach_impl cfgpybind
+ if [[ ${ABI} == ${DEFAULT_ABI} ]] ; then
+ if use python ; then
+ cfgpybind() {
+ local mycmakeargs=(
+ -DBUILD_PYTHON_BINDINGS=ON
+ -DCMAKE_SKIP_RPATH=YES
+ )
+ BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
+ }
+ einfo "configuring python binding"
+ python_foreach_impl cfgpybind
+ fi
fi
}
-src_compile() {
+multilib_src_compile() {
cmake-utils_src_compile
- if use python ; then
- buildpybind() {
- cp "${WORKDIR}"/${P}_build/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
- BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
- }
- einfo "compiling python binding"
- python_foreach_impl buildpybind
+ if [[ ${ABI} == ${DEFAULT_ABI} ]] ; then
+ if use python ; then
+ buildpybind() {
+ cp "${S}-${ABI}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
+ BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
+ }
+ einfo "compiling python binding"
+ python_foreach_impl buildpybind
+ fi
fi
}
-src_install() {
+multilib_src_install() {
cmake-utils_src_install
- if use python ; then
- instpybind() {
- python_domodule bin/rocket.py
- exeinto "$(python_get_sitedir)"
- doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
- }
- einfo "installing python binding"
- python_foreach_impl instpybind
+ if [[ ${ABI} == ${DEFAULT_ABI} ]] ; then
+ if use python ; then
+ instpybind() {
+ python_domodule "${S}"/bin/rocket.py
+ exeinto "$(python_get_sitedir)"
+ doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
+ }
+ einfo "installing python binding"
+ python_foreach_impl instpybind
+ fi
fi
}