summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2004-07-06 19:42:37 +0000
committerTom William Payne <twp@gentoo.org>2004-07-06 19:42:37 +0000
commitb555a5e2159079dabfd6034bad7e036d29d0c638 (patch)
tree5b501ad7d7c8b87c8062fe70616fd308abc6d9d7 /dev-libs/judy/judy-20020627-r1.ebuild
parentChangelog typo (Manifest recommit) (diff)
downloadgentoo-2-b555a5e2159079dabfd6034bad7e036d29d0c638.tar.gz
gentoo-2-b555a5e2159079dabfd6034bad7e036d29d0c638.tar.bz2
gentoo-2-b555a5e2159079dabfd6034bad7e036d29d0c638.zip
Fix compile problems with recent gccs. Bug # 51528. Thanks J.C. Wren.
Diffstat (limited to 'dev-libs/judy/judy-20020627-r1.ebuild')
-rw-r--r--dev-libs/judy/judy-20020627-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/judy/judy-20020627-r1.ebuild b/dev-libs/judy/judy-20020627-r1.ebuild
new file mode 100644
index 000000000000..c8b41abafe46
--- /dev/null
+++ b/dev-libs/judy/judy-20020627-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/judy/judy-20020627-r1.ebuild,v 1.1 2004/07/06 19:42:37 twp Exp $
+
+DESCRIPTION="A C library that implements a dynamic array"
+HOMEPAGE="http://judy.sourceforge.net/"
+MY_PN=${PN/judy/Judy}
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-initial_LGPL.src.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=""
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-initial_LGPL"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/tool
+ epatch ${FILESDIR}/jhton.patch
+ cd ${S}
+
+ # Modify the Makefile so that it doesn't try
+ # install itself into /opt and create symlinks
+ # everywhere, nor try to bzip2 the man pages.
+ #
+ # This is likely to break in the next release,
+ # so be careful.
+
+ mv Makefile.multi Makefile.multi.orig || die
+ sed -e "s|/opt/Judy|${D}|" \
+ -e 's#| $(COMPRESSPATH)##' \
+ -e '2410s|$(DELDIR)|$(DELDIR)/*|' \
+ -e '2414s|&&.*||' \
+ -e '2409d' -e '2415,2419d' \
+ Makefile.multi.orig > Makefile.multi || die
+}
+
+src_compile() {
+ cd ${S}
+ ./configure || die "./configure failed"
+ make MANFILE_SUFFIX='' || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}