summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2006-11-16 11:22:03 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2006-11-16 11:22:03 +0000
commitebd22193d84f6aa2310975a4fe651691d6cfe5dd (patch)
tree57d0a7420ab6d02920b1fd567be63baead6a0f4b /dev-libs/hashit/hashit-0.9.4.ebuild
parentRemove tar-tree tests if we don't have unzip installed. (diff)
downloadgentoo-2-ebd22193d84f6aa2310975a4fe651691d6cfe5dd.tar.gz
gentoo-2-ebd22193d84f6aa2310975a4fe651691d6cfe5dd.tar.bz2
gentoo-2-ebd22193d84f6aa2310975a4fe651691d6cfe5dd.zip
Upgraded version, fixes bug #151723.
Diffstat (limited to 'dev-libs/hashit/hashit-0.9.4.ebuild')
-rw-r--r--dev-libs/hashit/hashit-0.9.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/hashit/hashit-0.9.4.ebuild b/dev-libs/hashit/hashit-0.9.4.ebuild
new file mode 100644
index 000000000000..77c028c608aa
--- /dev/null
+++ b/dev-libs/hashit/hashit-0.9.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/hashit-0.9.4.ebuild,v 1.1 2006/11/16 11:22:03 pyrania Exp $
+
+DESCRIPTION="Hashit is a library of generic hash tables that supports different collision handling methods with one common interface. Both data and keys can be of any type. It is small and easy to use."
+HOMEPAGE="http://www.pleyades.net/david/projects/"
+SRC_URI="http://www.pleyades.net/david/projects/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ ./0 --prefix=${D}/usr --infodir=${D}/usr/share/info:${D}/usr/X11R6/info
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dosym libhashit.so /usr/lib/libhashit.so.0
+}