summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-12-10 19:16:27 +0000
committerPacho Ramos <pacho@gentoo.org>2010-12-10 19:16:27 +0000
commitf7f35b1508c345bcf295cb76419094fc8e251951 (patch)
tree2131cd7fa61f625599bad3ecf68fb8bb8b357b82 /dev-libs/gmime
parentVersion bump (diff)
downloadgentoo-2-f7f35b1508c345bcf295cb76419094fc8e251951.tar.gz
gentoo-2-f7f35b1508c345bcf295cb76419094fc8e251951.tar.bz2
gentoo-2-f7f35b1508c345bcf295cb76419094fc8e251951.zip
Version bump with upstream fixes, remove old testing.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/gmime')
-rw-r--r--dev-libs/gmime/ChangeLog8
-rw-r--r--dev-libs/gmime/gmime-2.4.21.ebuild (renamed from dev-libs/gmime/gmime-2.4.18.ebuild)36
2 files changed, 31 insertions, 13 deletions
diff --git a/dev-libs/gmime/ChangeLog b/dev-libs/gmime/ChangeLog
index b88c516a5514..a8ce2478e7b5 100644
--- a/dev-libs/gmime/ChangeLog
+++ b/dev-libs/gmime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gmime
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.129 2010/10/30 18:04:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.130 2010/12/10 19:16:27 pacho Exp $
+
+*gmime-2.4.21 (10 Dec 2010)
+
+ 10 Dec 2010; Pacho Ramos <pacho@gentoo.org> -gmime-2.4.18.ebuild,
+ +gmime-2.4.21.ebuild:
+ Version bump with upstream fixes, remove old testing.
30 Oct 2010; Raúl Porcel <armin76@gentoo.org> gmime-2.4.19.ebuild:
alpha/ia64/sparc stable wrt #340198
diff --git a/dev-libs/gmime/gmime-2.4.18.ebuild b/dev-libs/gmime/gmime-2.4.21.ebuild
index f8e88132558f..d06409b1b034 100644
--- a/dev-libs/gmime/gmime-2.4.18.ebuild
+++ b/dev-libs/gmime/gmime-2.4.21.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.18.ebuild,v 1.1 2010/08/29 21:03:35 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.21.ebuild,v 1.1 2010/12/10 19:16:27 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
inherit gnome2 eutils mono libtool
@@ -24,17 +27,18 @@ DEPEND="${RDEPEND}
app-text/docbook-sgml-utils )
mono? ( dev-dotnet/gtk-sharp-gapi )"
-DOCS="AUTHORS ChangeLog NEWS PORTING README TODO doc/html/"
+DOCS="AUTHORS ChangeLog NEWS PORTING README TODO"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ gnome2_src_prepare
if use doc ; then
# db2html should be docbook2html
+ sed -i -e 's:db2html:docbook2html:' \
+ configure.in configure || die "sed failed (1)"
sed -i -e 's:db2html:docbook2html -o gmime-tut:g' \
docs/tutorial/Makefile.am docs/tutorial/Makefile.in \
- || die "sed failed (1)"
+ || die "sed failed (2)"
# Fix doc targets (bug #97154)
sed -i -e 's!\<\(tmpl-build.stamp\): !\1 $(srcdir)/tmpl/*.sgml: !' \
gtk-doc.make docs/reference/Makefile.in || die "sed failed (3)"
@@ -44,19 +48,25 @@ src_unpack() {
sed -i -e 's:^libdir.*:libdir=@libdir@:' \
-e 's:^prefix=:exec_prefix=:' \
-e 's:prefix)/lib:libdir):' \
- mono/gmime-sharp-2.4.pc.in mono/Makefile.{am,in} || die "sed failed (2)"
+ mono/gmime-sharp-2.4.pc.in mono/Makefile.{am,in} || die "sed failed (4)"
elibtoolize
}
-src_compile() {
+src_configure() {
econf $(use_enable mono) $(use_enable doc gtk-doc) --enable-cryptography
+}
+
+src_compile() {
MONO_PATH="${S}" emake || die "emake failed"
+ if use doc; then
+ emake -C docs/tutorial html || die "emake html failed"
+ fi
}
src_install() {
- emake GACUTIL_FLAGS="/root '${D}/usr/$(get_libdir)' /gacdir /usr/$(get_libdir) /package ${PN}" \
- DESTDIR="${D}" install || die "installation failed"
+ emake GACUTIL_FLAGS="/root '${ED}/usr/$(get_libdir)' /gacdir /usr/$(get_libdir) /package ${PN}" \
+ DESTDIR="${ED}" install || die "installation failed"
if use doc ; then
# we don't use docinto/dodoc, because we don't want html doc gzipped
@@ -64,8 +74,10 @@ src_install() {
doins docs/tutorial/html/*
fi
+ dodoc $DOCS || die "dodoc failed"
+
# rename these two, so they don't conflict with app-arch/sharutils
# (bug #70392) Ticho, 2004-11-10
- mv "${D}/usr/bin/uuencode" "${D}/usr/bin/gmime-uuencode-${SLOT}"
- mv "${D}/usr/bin/uudecode" "${D}/usr/bin/gmime-uudecode-${SLOT}"
+ mv "${ED}/usr/bin/uuencode" "${ED}/usr/bin/gmime-uuencode-${SLOT}"
+ mv "${ED}/usr/bin/uudecode" "${ED}/usr/bin/gmime-uudecode-${SLOT}"
}