summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-12-04 20:11:36 +0000
committerPacho Ramos <pacho@gentoo.org>2010-12-04 20:11:36 +0000
commitaf7ed460ec469adbc52abb5819f81231cbb7cd9a (patch)
treeffb00e8cf59435aaebb037cd3b55592662207153 /dev-libs/glib
parentMove activeresource into the right SLOT. (diff)
downloadgentoo-2-af7ed460ec469adbc52abb5819f81231cbb7cd9a.tar.gz
gentoo-2-af7ed460ec469adbc52abb5819f81231cbb7cd9a.tar.bz2
gentoo-2-af7ed460ec469adbc52abb5819f81231cbb7cd9a.zip
Version bump with bugfixes and translation updates, remove old and skip tests building when unneeded.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog9
-rw-r--r--dev-libs/glib/glib-2.26.1.ebuild (renamed from dev-libs/glib/glib-2.25.17.ebuild)44
2 files changed, 41 insertions, 12 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 5a4fa5650552..7bbabe14b305 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.430 2010/10/17 15:12:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.431 2010/12/04 20:11:36 pacho Exp $
+
+*glib-2.26.1 (04 Dec 2010)
+
+ 04 Dec 2010; Pacho Ramos <pacho@gentoo.org> -glib-2.25.17.ebuild,
+ +glib-2.26.1.ebuild:
+ Version bump with bugfixes and translation updates, remove old and skip tests
+ building when unneeded.
*glib-2.26.0-r1 (17 Oct 2010)
diff --git a/dev-libs/glib/glib-2.25.17.ebuild b/dev-libs/glib/glib-2.26.1.ebuild
index 50282b4fbadf..b380d3c501e7 100644
--- a/dev-libs/glib/glib-2.25.17.ebuild
+++ b/dev-libs/glib/glib-2.26.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.25.17.ebuild,v 1.3 2010/09/25 14:59:47 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.26.1.ebuild,v 1.1 2010/12/04 20:11:36 pacho Exp $
-EAPI="2"
+EAPI="3"
-inherit autotools gnome.org libtool eutils flag-o-matic
+inherit autotools gnome.org libtool eutils flag-o-matic pax-utils
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.gtk.org/"
LICENSE="LGPL-2"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc fam hardened +introspection selinux static-libs test xattr"
+IUSE="debug doc fam +introspection selinux +static-libs test xattr"
RDEPEND="virtual/libiconv
sys-libs/zlib
@@ -21,12 +21,15 @@ RDEPEND="virtual/libiconv
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.16
>=sys-devel/gettext-0.11
+ >=dev-util/gtk-doc-am-1.13
doc? (
>=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.11
+ >=dev-util/gtk-doc-1.13
~app-text/docbook-xml-dtd-4.1.2 )
test? ( >=sys-apps/dbus-1.2.14 )"
PDEPEND="introspection? ( dev-libs/gobject-introspection )"
+
+# eautoreconf needs gtk-doc-am
# XXX: Consider adding test? ( sys-devel/gdb ); assert-msg-test tries to use it
src_prepare() {
@@ -60,7 +63,18 @@ src_prepare() {
sed 's:^\(.*"/desktop-app-info/delete".*\):/*\1*/:' \
-i "${S}"/gio/tests/desktop-app-info.c || die "sed failed"
+ # Disable failing tests, upstream bug #???
+ epatch "${FILESDIR}/${PN}-2.26.0-disable-locale-sensitive-test.patch"
+ epatch "${FILESDIR}/${PN}-2.26.0-disable-volumemonitor-broken-test.patch"
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
# Needed for the punt-python-check patch.
+ # Also needed to prevent croscompile failures, see bug #267603
eautoreconf
[[ ${CHOST} == *-freebsd* ]] && elibtoolize
@@ -75,7 +89,8 @@ src_configure() {
# an unusable form as it disables some commonly used API. Please do not
# convert this to the use_enable form, as it results in a broken build.
# -- compnerd (3/27/06)
- use debug && myconf="--enable-debug"
+ # disable-visibility needed for reference debug, bug #274647
+ use debug && myconf="--enable-debug --disable-visibility"
# Always use internal libpcre, bug #254659
econf ${myconf} \
@@ -92,21 +107,21 @@ src_configure() {
src_install() {
local f
- emake DESTDIR="${D}" install || die "Installation failed"
+ emake DESTDIR="${ED}" install || die "Installation failed"
# Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${D}/usr/lib/charset.alias"
+ rm -f "${ED}/usr/lib/charset.alias"
# Don't install gdb python macros, bug 291328
- rm -rf "${D}/usr/share/gdb/" "${D}/usr/share/glib-2.0/gdb/"
+ rm -rf "${ED}/usr/share/gdb/" "${ED}/usr/share/glib-2.0/gdb/"
dodoc AUTHORS ChangeLog* NEWS* README || die "dodoc failed"
insinto /usr/share/bash-completion
for f in gdbus gsettings; do
- newins "${D}/etc/bash_completion.d/${f}-bash-completion.sh" ${f} || die
+ newins "${ED}/etc/bash_completion.d/${f}-bash-completion.sh" ${f} || die
done
- rm -rf "${D}/etc"
+ rm -rf "${ED}/etc"
}
src_test() {
@@ -114,6 +129,13 @@ src_test() {
export XDG_CONFIG_DIRS=/etc/xdg
export XDG_DATA_DIRS=/usr/local/share:/usr/share
export XDG_DATA_HOME="${T}"
+
+ # Hardened: gdb needs this, bug #338891
+ if host-is-pax ; then
+ pax-mark -mr "${S}"/tests/.libs/assert-msg-test \
+ || die "Hardened adjustment failed"
+ fi
+
emake check || die "tests failed"
}