summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-24 03:28:24 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-24 03:28:24 +0000
commitaf496da6ce325f5bbd15ee6a23587be9199b792d (patch)
treee8c3e8467b4793c5cbdfe15042789fbe7f327bac /dev-libs/glib
parentppc (Manifest recommit) (diff)
downloadgentoo-2-af496da6ce325f5bbd15ee6a23587be9199b792d.tar.gz
gentoo-2-af496da6ce325f5bbd15ee6a23587be9199b792d.tar.bz2
gentoo-2-af496da6ce325f5bbd15ee6a23587be9199b792d.zip
Instead of being choosy about what arches to use -fPIC on, just use it on all of them. This fixes bug 48839 (pam fails to build on ia64)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog6
-rw-r--r--dev-libs/glib/glib-1.2.10-r5.ebuild16
-rw-r--r--dev-libs/glib/glib-2.2.1.ebuild4
3 files changed, 16 insertions, 10 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index b08246df07b7..bf65d4c3bbfe 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/glib
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.67 2004/04/19 22:48:52 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.68 2004/04/24 03:28:24 agriffis Exp $
+
+ 23 Apr 2004; Aron Griffis <agriffis@gentoo.org> glib-1.2.10-r5.ebuild:
+ Instead of being choosy about what arches to use -fPIC on, just use it on all
+ of them. This fixes bug 48839 (pam fails to build on ia64)
19 Apr 2004; Jon Portnoy <avenj@gentoo.org> glib-1.2.10-r5.ebuild :
Call gnuconfig_update on AMD64 to fix AMD64 bootstrap breakage.
diff --git a/dev-libs/glib/glib-1.2.10-r5.ebuild b/dev-libs/glib/glib-1.2.10-r5.ebuild
index 4a002aaf3b69..77738791e89e 100644
--- a/dev-libs/glib/glib-1.2.10-r5.ebuild
+++ b/dev-libs/glib/glib-1.2.10-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r5.ebuild,v 1.19 2004/04/19 22:48:52 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r5.ebuild,v 1.20 2004/04/24 03:28:24 agriffis Exp $
-inherit libtool gnuconfig
+inherit libtool gnuconfig flag-o-matic
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
@@ -44,16 +44,18 @@ src_compile() {
# Brad House <brad_mssw@gentoo.org> 1/2/2004
# libtoolize -c -f
+ # Bug 48839: pam fails to build on ia64
+ # The problem is that it attempts to link a shared object against
+ # libglib.a; this library needs to be built with -fPIC. Since
+ # this package doesn't contain any significant binaries, build the
+ # whole thing with -fPIC (23 Apr 2004 agriffis)
+ append-flags -fPIC
econf \
--with-threads=posix \
--enable-debug=yes || die
- if [ "${ARCH}" = "alpha" -o "${ARCH}" = "amd64" -o "${ARCH}" = "hppa" ] ; then
- emake CFLAGS="${CFLAGS} -fPIC" || die
- else
- emake || die
- fi
+ emake || die
}
src_install() {
diff --git a/dev-libs/glib/glib-2.2.1.ebuild b/dev-libs/glib/glib-2.2.1.ebuild
index c05a501d0994..4d919b1e7c46 100644
--- a/dev-libs/glib/glib-2.2.1.ebuild
+++ b/dev-libs/glib/glib-2.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.2.1.ebuild,v 1.14 2004/02/22 20:02:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.2.1.ebuild,v 1.15 2004/04/24 03:28:24 agriffis Exp $
inherit libtool