summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-04-19 22:48:52 +0000
committerJon Portnoy <avenj@gentoo.org>2004-04-19 22:48:52 +0000
commit921a2ac5796ea6139475482c3bb71f8b2786a4e4 (patch)
tree66bdff54e3d611cd86eb1d469d41173581544c74 /dev-libs/glib
parentAdded ~alpha to keywords. (Manifest recommit) (diff)
downloadgentoo-2-921a2ac5796ea6139475482c3bb71f8b2786a4e4.tar.gz
gentoo-2-921a2ac5796ea6139475482c3bb71f8b2786a4e4.tar.bz2
gentoo-2-921a2ac5796ea6139475482c3bb71f8b2786a4e4.zip
call gnuconfig_update on amd64 to fix amd64 bootstrap breakage. see the comments in the ebuild and bug 47950 for more information
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog6
-rw-r--r--dev-libs/glib/glib-1.2.10-r5.ebuild22
2 files changed, 23 insertions, 5 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index db7255c6fe98..b08246df07b7 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/glib
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.66 2004/04/17 18:28:01 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.67 2004/04/19 22:48:52 avenj Exp $
+
+ 19 Apr 2004; Jon Portnoy <avenj@gentoo.org> glib-1.2.10-r5.ebuild :
+ Call gnuconfig_update on AMD64 to fix AMD64 bootstrap breakage.
+ See the comments in the ebuild and bug #47950 for more information.
17 Apr 2004; Guy Martin <gmsoft@gentoo.org> glib-1.2.10-r5.ebuild:
Added -fPIC to CFLAGS for hppa.
diff --git a/dev-libs/glib/glib-1.2.10-r5.ebuild b/dev-libs/glib/glib-1.2.10-r5.ebuild
index 48a50cba8525..4a002aaf3b69 100644
--- a/dev-libs/glib/glib-1.2.10-r5.ebuild
+++ b/dev-libs/glib/glib-1.2.10-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r5.ebuild,v 1.18 2004/04/17 18:28:01 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r5.ebuild,v 1.19 2004/04/19 22:48:52 avenj Exp $
-inherit libtool
+inherit libtool gnuconfig
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
@@ -24,12 +24,26 @@ src_unpack() {
}
src_compile() {
-# elibtoolize
+ elibtoolize
+
+ # elibtoolize breaks (see brad's comments below, left here for
+ # historical purposes) but libtoolize won't work either because
+ # there is no libtoolize in the stage1 and it brings in nasty
+ # deps if you try to install it during bootstrap.
+ # elibtoolize seems to be working decently on x86. As a temporary
+ # fix for amd64 users to be able to bootstrap, we run gnuconfig.
+ # The glib .a's will be broken, but it's a start.
+ # See bug 47950 for more information.
+ # -- avenj@gentoo.org 19 Apr 04
+
+ use amd64 && gnuconfig_update
+
# For some reason, elibtoolize stopped doing its job in the last couple
# of days on this ebuild, and amd64 won't compile it anymore, need to
# manually run libtoolize, I need to inspect the libtool.eclass I guess.
# Brad House <brad_mssw@gentoo.org> 1/2/2004
- libtoolize -c -f
+# libtoolize -c -f
+
econf \
--with-threads=posix \