summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-04 12:49:13 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-04 12:49:13 +0000
commit0ff7145dee116f0e3a8b9061bac18fe8a7ea7779 (patch)
tree31bb9b67f0d0369e3a607882e18201e453d491ed /dev-libs/g-wrap
parentNice little gcc-3.x compile fix, works on 2.95.3 too (diff)
downloadgentoo-2-0ff7145dee116f0e3a8b9061bac18fe8a7ea7779.tar.gz
gentoo-2-0ff7145dee116f0e3a8b9061bac18fe8a7ea7779.tar.bz2
gentoo-2-0ff7145dee116f0e3a8b9061bac18fe8a7ea7779.zip
GCC3.1 compile fixes tested on 2.95.3 too
Diffstat (limited to 'dev-libs/g-wrap')
-rw-r--r--dev-libs/g-wrap/files/digest-g-wrap-1.2.1-r21
-rw-r--r--dev-libs/g-wrap/files/digest-g-wrap-1.3.1-r11
-rw-r--r--dev-libs/g-wrap/g-wrap-1.2.1-r2.ebuild47
-rw-r--r--dev-libs/g-wrap/g-wrap-1.3.1-r1.ebuild42
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/g-wrap/files/digest-g-wrap-1.2.1-r2 b/dev-libs/g-wrap/files/digest-g-wrap-1.2.1-r2
new file mode 100644
index 000000000000..7ad337466984
--- /dev/null
+++ b/dev-libs/g-wrap/files/digest-g-wrap-1.2.1-r2
@@ -0,0 +1 @@
+MD5 9406339bb3f04c08448f4bab3c537ce7 g-wrap-1.2.1.tar.gz 349469
diff --git a/dev-libs/g-wrap/files/digest-g-wrap-1.3.1-r1 b/dev-libs/g-wrap/files/digest-g-wrap-1.3.1-r1
new file mode 100644
index 000000000000..44d6fbc296f9
--- /dev/null
+++ b/dev-libs/g-wrap/files/digest-g-wrap-1.3.1-r1
@@ -0,0 +1 @@
+MD5 3f186c0f5839ee253d411fdf565d974b g-wrap-1.3.1.tar.gz 352352
diff --git a/dev-libs/g-wrap/g-wrap-1.2.1-r2.ebuild b/dev-libs/g-wrap/g-wrap-1.2.1-r2.ebuild
new file mode 100644
index 000000000000..0367d7143366
--- /dev/null
+++ b/dev-libs/g-wrap/g-wrap-1.2.1-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/g-wrap/g-wrap-1.2.1-r2.ebuild,v 1.1 2002/06/04 12:49:13 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A tool for exporting C libraries into Scheme"
+SRC_URI="http://www.gnucash.org/pub/g-wrap/source/${P}.tar.gz"
+HOMEPAGE="http://"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=dev-util/guile-1.4
+ >=dev-libs/slib-2.4.1"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+}
+
+src_compile() {
+
+ # fix the "relink" bug in older versions of libtool
+ libtoolize --copy --force
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/misc \
+ --infodir=/usr/share/info || die
+
+ #GCC3 Compile fix, I tried to do this at the Makefile.in level
+ #but it hates me with a passion so it goes here.
+ for FILE in `find . -iname "Makefile"`
+ do
+ mv ${FILE} ${FILE}.old
+ sed -e "s:-I/usr/include::" ${FILE}.old > ${FILE}
+ done
+
+ make || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+}
+
diff --git a/dev-libs/g-wrap/g-wrap-1.3.1-r1.ebuild b/dev-libs/g-wrap/g-wrap-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..0e33efd3026e
--- /dev/null
+++ b/dev-libs/g-wrap/g-wrap-1.3.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/g-wrap/g-wrap-1.3.1-r1.ebuild,v 1.1 2002/06/04 12:49:13 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A tool for exporting C libraries into Scheme"
+SRC_URI="ftp://ftp.gnucash.org/pub/g-wrap/source/${P}.tar.gz"
+HOMEPAGE="http://"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=dev-util/guile-1.4
+ >=dev-libs/slib-2.4.1"
+
+
+src_unpack() {
+
+ unpack ${A}
+}
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/misc \
+ --infodir=/usr/share/info || die
+
+ #GCC3 Compile fix, I tried to do this at the Makefile.in level
+ #but it hates me with a passion so it goes here.
+ for FILE in `find . -iname "Makefile"`
+ do
+ mv ${FILE} ${FILE}.old
+ sed -e "s:-I/usr/include::" ${FILE}.old > ${FILE}
+ done
+
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+}