summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-04-17 21:33:48 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-04-17 21:33:48 +0000
commit6bcd24064e3bf7af166baaedf743829a9b642d95 (patch)
tree9adcc3236f4a76c9db02bc107752558db22a7539 /dev-libs/expat
parentRespect user CFLAGS except for any -O flags as that causes segfaults on 48kHz... (diff)
downloadgentoo-2-6bcd24064e3bf7af166baaedf743829a9b642d95.tar.gz
gentoo-2-6bcd24064e3bf7af166baaedf743829a9b642d95.tar.bz2
gentoo-2-6bcd24064e3bf7af166baaedf743829a9b642d95.zip
Additional fixes for the tests suite.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-libs/expat')
-rw-r--r--dev-libs/expat/ChangeLog9
-rw-r--r--dev-libs/expat/expat-2.0.0.ebuild7
-rw-r--r--dev-libs/expat/files/expat-2.0.0-test-64bit.patch2
-rw-r--r--dev-libs/expat/files/expat-2.0.0-test-cpp.patch22
4 files changed, 35 insertions, 5 deletions
diff --git a/dev-libs/expat/ChangeLog b/dev-libs/expat/ChangeLog
index 3b166d277f40..40000413d361 100644
--- a/dev-libs/expat/ChangeLog
+++ b/dev-libs/expat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/expat
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.52 2006/04/12 22:14:26 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.53 2006/04/17 21:33:48 exg Exp $
+
+ 17 Apr 2006; Emanuele Giaquinta <exg@gentoo.org>
+ files/expat-2.0.0-test-64bit.patch, +files/expat-2.0.0-test-cpp.patch,
+ expat-2.0.0.ebuild:
+ Add patch to fix bug #128143 (thanks Flameeyes) and to add missing
+ definition for CXX in Makefile.in; use elibtoolize again since the
+ bundled ltmain.sh behaves correctly now.
12 Apr 2006; Emanuele Giaquinta <exg@gentoo.org>
+files/expat-2.0.0-test-64bit.patch, expat-2.0.0.ebuild:
diff --git a/dev-libs/expat/expat-2.0.0.ebuild b/dev-libs/expat/expat-2.0.0.ebuild
index 6ab4f210185f..24e1ae58e3ef 100644
--- a/dev-libs/expat/expat-2.0.0.ebuild
+++ b/dev-libs/expat/expat-2.0.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.0.0.ebuild,v 1.4 2006/04/12 22:14:26 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.0.0.ebuild,v 1.5 2006/04/17 21:33:48 exg Exp $
-inherit autotools
+inherit eutils libtool
DESCRIPTION="XML parsing libraries"
HOMEPAGE="http://expat.sourceforge.net/"
@@ -20,7 +20,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch ${FILESDIR}/${P}-test-64bit.patch
- eautoreconf
+ epatch ${FILESDIR}/${P}-test-cpp.patch
+ elibtoolize
}
src_install() {
diff --git a/dev-libs/expat/files/expat-2.0.0-test-64bit.patch b/dev-libs/expat/files/expat-2.0.0-test-64bit.patch
index 07d7b643089d..3c65a945949f 100644
--- a/dev-libs/expat/files/expat-2.0.0-test-64bit.patch
+++ b/dev-libs/expat/files/expat-2.0.0-test-64bit.patch
@@ -5,7 +5,7 @@
const XML_Char *publicId)
{
- int callno = 1 + (int)XML_GetUserData(parser);
-+ long callno = 1 + (int)XML_GetUserData(parser);
++ long callno = 1 + (long)XML_GetUserData(parser);
char *text;
XML_Parser p2;
diff --git a/dev-libs/expat/files/expat-2.0.0-test-cpp.patch b/dev-libs/expat/files/expat-2.0.0-test-cpp.patch
new file mode 100644
index 000000000000..d3b4ce7d4f9b
--- /dev/null
+++ b/dev-libs/expat/files/expat-2.0.0-test-cpp.patch
@@ -0,0 +1,22 @@
+--- Makefile.in.old 2006-04-17 21:28:36.000000000 +0200
++++ Makefile.in 2006-04-17 21:34:50.000000000 +0200
+@@ -103,6 +103,7 @@
+ done
+
+ CC = @CC@
++CXX = @CXX@
+ LIBTOOL = @LIBTOOL@
+
+ INCLUDES = -I$(srcdir)/lib -I.
+@@ -172,8 +173,10 @@
+ run-xmltest: xmlwf/xmlwf tests/XML-Test-Suite
+ tests/xmltest.sh
+
+-.SUFFIXES: .c .lo .o
++.SUFFIXES: .c .cpp .lo .o
+
++.cpp.o:
++ $(CXXCOMPILE) -o $@ -c $<
+ .c.o:
+ $(COMPILE) -o $@ -c $<
+ .c.lo: