summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-21 22:48:49 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-21 22:48:49 +0000
commit02110443812d18a8f15e6ca38312e32379adaa33 (patch)
treec4edec7a334c8d545211373154a8203e3758ba22 /dev-libs/expat
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-02110443812d18a8f15e6ca38312e32379adaa33.tar.gz
gentoo-2-02110443812d18a8f15e6ca38312e32379adaa33.tar.bz2
gentoo-2-02110443812d18a8f15e6ca38312e32379adaa33.zip
Add epunt_cxx per bug #185252. Add die messages and use emake.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/expat')
-rw-r--r--dev-libs/expat/ChangeLog6
-rw-r--r--dev-libs/expat/expat-1.95.8.ebuild39
-rw-r--r--dev-libs/expat/expat-2.0.1-r1.ebuild11
-rw-r--r--dev-libs/expat/expat-2.0.1.ebuild35
4 files changed, 11 insertions, 80 deletions
diff --git a/dev-libs/expat/ChangeLog b/dev-libs/expat/ChangeLog
index 6be2b9057e50..95a4aed89b50 100644
--- a/dev-libs/expat/ChangeLog
+++ b/dev-libs/expat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/expat
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.79 2009/03/17 10:48:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.80 2009/03/21 22:48:49 eva Exp $
+
+ 21 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org> -expat-1.95.8.ebuild,
+ -expat-2.0.1.ebuild, expat-2.0.1-r1.ebuild:
+ Add epunt_cxx per bug #185252. Add die messages and use emake.
17 Mar 2009; Raúl Porcel <armin76@gentoo.org> expat-2.0.1-r1.ebuild:
m68k stable wrt #252607, thanks to kolla for testing
diff --git a/dev-libs/expat/expat-1.95.8.ebuild b/dev-libs/expat/expat-1.95.8.ebuild
deleted file mode 100644
index 6eb2bb733d42..000000000000
--- a/dev-libs/expat/expat-1.95.8.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.8.ebuild,v 1.22 2008/03/10 01:39:03 ricmm Exp $
-
-inherit libtool multilib
-
-DESCRIPTION="XML parsing libraries"
-HOMEPAGE="http://expat.sourceforge.net/"
-SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="test"
-
-DEPEND="test? ( >=dev-libs/check-0.8 )"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- elibtoolize
-}
-
-src_test() {
- if ! use test && [[ -z $(best_version dev-libs/check) ]] ; then
- ewarn "You dont have USE=test and dev-libs/check is not installed."
- ewarn "src_test will be skipped."
- return 0
- fi
- make check || die "make check failed"
-}
-
-src_install() {
- einstall man1dir="${D}/usr/share/man/man1" || die "einstall failed"
- dosed /usr/$(get_libdir)/libexpat.la #81568
- dodoc Changes README
- dohtml doc/*
-}
diff --git a/dev-libs/expat/expat-2.0.1-r1.ebuild b/dev-libs/expat/expat-2.0.1-r1.ebuild
index a56487f5225f..16d18f9e72b2 100644
--- a/dev-libs/expat/expat-2.0.1-r1.ebuild
+++ b/dev-libs/expat/expat-2.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.0.1-r1.ebuild,v 1.9 2009/03/17 10:48:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.0.1-r1.ebuild,v 1.10 2009/03/21 22:48:49 eva Exp $
inherit eutils libtool
@@ -13,8 +13,8 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
IUSE=""
-DEPEND=""
RDEPEND=""
+DEPEND=""
src_unpack() {
unpack ${A}
@@ -24,12 +24,13 @@ src_unpack() {
epatch "${FILESDIR}/${P}-check_stopped_parser.patch"
elibtoolize
+ epunt_cxx
}
src_install() {
- make install DESTDIR="${D}" || die
- dodoc Changes README
- dohtml doc/*
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc Changes README || die "dodoc failed"
+ dohtml doc/* || die "dohtml failed"
}
pkg_postinst() {
diff --git a/dev-libs/expat/expat-2.0.1.ebuild b/dev-libs/expat/expat-2.0.1.ebuild
deleted file mode 100644
index 400f34ae4c3f..000000000000
--- a/dev-libs/expat/expat-2.0.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.0.1.ebuild,v 1.12 2007/10/27 15:15:01 flameeyes Exp $
-
-inherit eutils libtool
-
-DESCRIPTION="XML parsing libraries"
-HOMEPAGE="http://expat.sourceforge.net/"
-SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- elibtoolize
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- dodoc Changes README
- dohtml doc/*
-}
-
-pkg_postinst() {
- ewarn "Please note that the soname of the library changed!"
- ewarn "If you are upgrading from a previous version you need"
- ewarn "to fix dynamic linking inconsistencies by executing:"
- ewarn "revdep-rebuild -X --library libexpat.so.0"
-}