summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Seidel <tuxus@gentoo.org>2004-02-22 22:32:05 +0000
committerJan Seidel <tuxus@gentoo.org>2004-02-22 22:32:05 +0000
commit7710f464e835496b6c023751247c59a12e37aecb (patch)
treef39bc53db40dd1ccd19a3de1fceacf76e5389c24 /dev-libs/elfutils
parentRemove arm keywords (Manifest recommit) (diff)
downloadgentoo-2-7710f464e835496b6c023751247c59a12e37aecb.tar.gz
gentoo-2-7710f464e835496b6c023751247c59a12e37aecb.tar.bz2
gentoo-2-7710f464e835496b6c023751247c59a12e37aecb.zip
files/elfutils-0.89-alpha-mips-atime.diff: \ Fix 0.89 compilation on mips
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/ChangeLog5
-rw-r--r--dev-libs/elfutils/elfutils-0.89.ebuild6
-rw-r--r--dev-libs/elfutils/files/elfutils-0.89-alpha-mips-atime.diff21
3 files changed, 28 insertions, 4 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index 4bfa9b185ca3..31deb35fa17c 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/elfutils
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.28 2004/02/22 19:13:21 tuxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.29 2004/02/22 22:32:05 tuxus Exp $
+
+ 22 Feb 2004; <tuxus@gentoo.org> elfutils-0.89.ebuild:
+ files/elfutils-0.89-alpha-mips-atime.diff: Fix 0.89 compilation on mips
22 Feb 2004; <tuxus@gentoo.org> elfutils-0.84.ebuild:
Fix 0.84 compilation on mips
diff --git a/dev-libs/elfutils/elfutils-0.89.ebuild b/dev-libs/elfutils/elfutils-0.89.ebuild
index 452c4f0090b0..d5fc05896f18 100644
--- a/dev-libs/elfutils/elfutils-0.89.ebuild
+++ b/dev-libs/elfutils/elfutils-0.89.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.89.ebuild,v 1.5 2003/12/31 20:19:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.89.ebuild,v 1.6 2004/02/22 22:32:05 tuxus Exp $
inherit eutils
@@ -27,7 +27,7 @@ src_unpack() {
${x}.orig > ${x}
done
- use alpha && epatch ${FILESDIR}/${P}-atime.diff
+ use mips || use alpha && epatch ${FILESDIR}/${P}-atime.diff
}
src_compile() {
diff --git a/dev-libs/elfutils/files/elfutils-0.89-alpha-mips-atime.diff b/dev-libs/elfutils/files/elfutils-0.89-alpha-mips-atime.diff
new file mode 100644
index 000000000000..0fb2add1e69a
--- /dev/null
+++ b/dev-libs/elfutils/files/elfutils-0.89-alpha-mips-atime.diff
@@ -0,0 +1,21 @@
+--- elfutils-0.89/src/strip.c.old 2003-09-26 08:01:49.000000000 +0200
++++ elfutils-0.89/src/strip.c 2004-02-22 22:20:42.000000000 +0100
+@@ -265,8 +265,16 @@
+
+ /* If we have to preserve the timestamp, we need it in the
+ format utimes() understands. */
+- TIMESPEC_TO_TIMEVAL (&tv[0], &pre_st.st_atim);
+- TIMESPEC_TO_TIMEVAL (&tv[1], &pre_st.st_mtim);
++
++#if defined ( __alpha ) || defined ( __mips)
++ tv[0].tv_sec = pre_st.st_atime;
++ tv[0].tv_usec = 0;
++ tv[1].tv_sec = pre_st.st_mtime;
++ tv[1].tv_usec = 0;
++#else
++ TIMESPEC_TO_TIMEVAL (&tv[0], &pre_st.st_atim);
++ TIMESPEC_TO_TIMEVAL (&tv[1], &pre_st.st_mtim);
++#endif
+ }
+
+ /* Open the file. */