summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2013-11-12 18:05:45 +0000
committerThomas Sachau <tommy@gentoo.org>2013-11-12 18:05:45 +0000
commit57996fb5792f0e8264b5f84c7294aaea8d661e79 (patch)
treece6e1ba307cb610dba4556b0ff49acdefdb448d5 /dev-libs/eet
parentppc stable wrt bug #480688 (diff)
downloadgentoo-2-57996fb5792f0e8264b5f84c7294aaea8d661e79.tar.gz
gentoo-2-57996fb5792f0e8264b5f84c7294aaea8d661e79.tar.bz2
gentoo-2-57996fb5792f0e8264b5f84c7294aaea8d661e79.zip
Version bump
(Portage version: 2.2.6-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'dev-libs/eet')
-rw-r--r--dev-libs/eet/ChangeLog7
-rw-r--r--dev-libs/eet/eet-1.7.9.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-libs/eet/ChangeLog b/dev-libs/eet/ChangeLog
index 3928a52b3923..b2f1ea49ea7b 100644
--- a/dev-libs/eet/ChangeLog
+++ b/dev-libs/eet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/eet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/eet/ChangeLog,v 1.30 2013/09/28 09:13:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eet/ChangeLog,v 1.31 2013/11/12 18:05:45 tommy Exp $
+
+*eet-1.7.9 (12 Nov 2013)
+
+ 12 Nov 2013; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> +eet-1.7.9.ebuild:
+ Version bump
*eet-9999 (28 Sep 2013)
diff --git a/dev-libs/eet/eet-1.7.9.ebuild b/dev-libs/eet/eet-1.7.9.ebuild
new file mode 100644
index 000000000000..6cf72229e25a
--- /dev/null
+++ b/dev-libs/eet/eet-1.7.9.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eet/eet-1.7.9.ebuild,v 1.1 2013/11/12 18:05:45 tommy Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="E file chunk reading/writing library"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Eet"
+
+LICENSE="BSD-2"
+IUSE="debug examples gnutls ssl static-libs test"
+
+RDEPEND=">=dev-libs/eina-${PV}
+ virtual/jpeg
+ sys-libs/zlib
+ gnutls? (
+ net-libs/gnutls
+ dev-libs/libgcrypt
+ )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/check
+ dev-util/lcov
+ )"
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable debug assert)
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable test tests)
+ )
+
+ if use gnutls; then
+ if use ssl; then
+ ewarn "You have enabled both 'ssl' and 'gnutls', so we will use"
+ ewarn "gnutls and not openssl for cipher and signature support"
+ fi
+ E_ECONF+=(
+ --enable-cipher
+ --enable-signature
+ --disable-openssl
+ --enable-gnutls
+ )
+ elif use ssl; then
+ E_ECONF+=(
+ --enable-cipher
+ --enable-signature
+ --enable-openssl
+ --disable-gnutls
+ )
+ else
+ E_ECONF+=(
+ --disable-cipher
+ --disable-signature
+ --disable-openssl
+ --disable-gnutls
+ )
+ fi
+
+ enlightenment_src_configure
+}