summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-10-27 19:07:26 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-10-27 19:07:26 +0000
commit423a12be6835e779c291f2fd28ce94ff86112da0 (patch)
tree1cdf48eb61f5f341e4fca4d0b8c0430b65f2541e /dev-libs/cyrus-imap-dev
parentVersion bump (diff)
downloadgentoo-2-423a12be6835e779c291f2fd28ce94ff86112da0.tar.gz
gentoo-2-423a12be6835e779c291f2fd28ce94ff86112da0.tar.bz2
gentoo-2-423a12be6835e779c291f2fd28ce94ff86112da0.zip
Version bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-libs/cyrus-imap-dev')
-rw-r--r--dev-libs/cyrus-imap-dev/ChangeLog8
-rw-r--r--dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.13.ebuild81
2 files changed, 88 insertions, 1 deletions
diff --git a/dev-libs/cyrus-imap-dev/ChangeLog b/dev-libs/cyrus-imap-dev/ChangeLog
index e02041da58f7..9892d6f5dcdf 100644
--- a/dev-libs/cyrus-imap-dev/ChangeLog
+++ b/dev-libs/cyrus-imap-dev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/cyrus-imap-dev
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-imap-dev/ChangeLog,v 1.48 2008/06/04 19:08:54 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-imap-dev/ChangeLog,v 1.49 2008/10/27 19:07:26 dertobi123 Exp $
+
+*cyrus-imap-dev-2.3.13 (27 Oct 2008)
+
+ 27 Oct 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +cyrus-imap-dev-2.3.13.ebuild:
+ Version bump
*cyrus-imap-dev-2.3.12_p2 (04 Jun 2008)
diff --git a/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.13.ebuild b/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.13.ebuild
new file mode 100644
index 000000000000..a682e599fab6
--- /dev/null
+++ b/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.13.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.13.ebuild,v 1.1 2008/10/27 19:07:26 dertobi123 Exp $
+
+inherit eutils autotools
+
+MY_PV="${PV/_/}"
+
+DESCRIPTION="Developer support for the Cyrus IMAP Server."
+HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~ppc64"
+IUSE="afs kerberos snmp ssl tcpd"
+
+RDEPEND="virtual/libc
+ >=sys-libs/db-3.2
+ >=dev-libs/cyrus-sasl-2.1.12
+ afs? ( >=net-fs/openafs-1.2.2 )
+ kerberos? ( >=app-crypt/mit-krb5-1.2.6 )
+ snmp? ( net-analyzer/net-snmp )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ >=sys-devel/autoconf-2.58
+ sys-devel/automake
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ # Add libwrap defines as we don't have a dynamicly linked library.
+ if use tcpd ; then
+ epatch "${FILESDIR}/cyrus-imapd-libwrap.patch" || die "patch failed"
+ fi
+
+ # DB4 detection and versioned symbols.
+ #epatch "${FILESDIR}/cyrus-imapd-${PV}-db4.patch" || die "patch failed."
+
+ # Recreate configure.
+ export WANT_AUTOCONF="2.5"
+ eautoreconf
+
+ # When linking with rpm, you need to link with more libraries.
+ sed -e "s:lrpm:lrpm -lrpmio -lrpmdb:" -i configure || die "sed failed"
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} `use_with afs`"
+ myconf="${myconf} `use_with ssl openssl`"
+ myconf="${myconf} `use_with snmp ucdsnmp`"
+ myconf="${myconf} `use_with tcpd libwrap`"
+ myconf="${myconf} `use_enable kerberos gssapi`"
+
+ econf \
+ --enable-murder \
+ --enable-listext \
+ --enable-netscapehack \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --with-auth=unix \
+ --without-perl \
+ --disable-cyradm \
+ ${myconf} || die "econf failed"
+
+ emake -C "${S}/lib" all || die "compile problem"
+}
+
+src_install() {
+ dodir /usr/include/cyrus
+
+ make -C "${S}/lib" DESTDIR="${D}" install || die "make install failed"
+ dodoc COPYRIGHT README*
+}