summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-03 16:11:31 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-03 16:11:31 +0000
commit394c166cc9cc28ed4213a9222bf71807efb8991c (patch)
treec9f211a6a467a84d19fa1d775f555572e7f9ce79 /dev-libs/cryptlib
parentAdded to ~ppc (diff)
downloadgentoo-2-394c166cc9cc28ed4213a9222bf71807efb8991c.tar.gz
gentoo-2-394c166cc9cc28ed4213a9222bf71807efb8991c.tar.bz2
gentoo-2-394c166cc9cc28ed4213a9222bf71807efb8991c.zip
Fix use invocation
Diffstat (limited to 'dev-libs/cryptlib')
-rw-r--r--dev-libs/cryptlib/ChangeLog8
-rw-r--r--dev-libs/cryptlib/cryptlib-3.0.ebuild4
-rw-r--r--dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild8
-rw-r--r--dev-libs/cryptlib/cryptlib-3.1_beta05.ebuild8
4 files changed, 16 insertions, 12 deletions
diff --git a/dev-libs/cryptlib/ChangeLog b/dev-libs/cryptlib/ChangeLog
index b2e2d927f2d5..c1024f6280cf 100644
--- a/dev-libs/cryptlib/ChangeLog
+++ b/dev-libs/cryptlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/cryptlib
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/ChangeLog,v 1.3 2003/10/09 23:56:25 mr_bones_ Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/ChangeLog,v 1.4 2004/06/03 16:11:31 agriffis Exp $
+
+ 03 Jun 2004; Aron Griffis <agriffis@gentoo.org> cryptlib-3.0.ebuild,
+ cryptlib-3.1_beta04.ebuild, cryptlib-3.1_beta05.ebuild:
+ Fix use invocation
*cryptlib-3.1_beta05 (09 Oct 2003)
diff --git a/dev-libs/cryptlib/cryptlib-3.0.ebuild b/dev-libs/cryptlib/cryptlib-3.0.ebuild
index e4ea819165b9..abe940d489df 100644
--- a/dev-libs/cryptlib/cryptlib-3.0.ebuild
+++ b/dev-libs/cryptlib/cryptlib-3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.0.ebuild,v 1.2 2004/03/14 12:28:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.0.ebuild,v 1.3 2004/06/03 16:11:31 agriffis Exp $
DESCRIPTION="powerful security toolkit for adding encryption to software"
HOMEPAGE="http://www.cs.auckland.ac.nz/~pgut001/cryptlib/"
@@ -22,7 +22,7 @@ src_unpack() {
src_compile() {
export SCFLAGS="-fpic -c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
export CFLAGS="-c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
- if [ `use static` ] ; then
+ if use static ; then
make CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || die "could not make static"
fi
make shared CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || die "could not make shared"
diff --git a/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild b/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild
index 7f74f8329496..f0183d6cf423 100644
--- a/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild
+++ b/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild,v 1.3 2004/03/14 12:28:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild,v 1.4 2004/06/03 16:11:31 agriffis Exp $
MY_PV=${PV/./}; MY_PV=${MY_PV/_/}
DESCRIPTION="Powerful security toolkit for adding encryption to software"
@@ -24,7 +24,7 @@ src_unpack() {
src_compile() {
export SCFLAGS="-fpic -c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
export CFLAGS="-c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
- if [ `use static` ] ; then
+ if use static ; then
emake CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || \
die "emake static failed"
fi
@@ -34,13 +34,13 @@ src_compile() {
src_install() {
dolib.so libcl.so* || die "dolib.so failed"
- if [ `use static` ] ; then
+ if use static ; then
dolib.a libcl.a || die "dolib.a failed"
fi
insinto /usr/include
doins cryptlib.h || die "doins failed"
dodoc README || die "dodoc failed"
- if [ `use doc` ] ; then
+ if use doc ; then
dodoc ${DISTDIR}/manual.pdf || die "dodoc failed (manual.pdf)"
fi
}
diff --git a/dev-libs/cryptlib/cryptlib-3.1_beta05.ebuild b/dev-libs/cryptlib/cryptlib-3.1_beta05.ebuild
index 5f2f546bf3c5..6edb28145555 100644
--- a/dev-libs/cryptlib/cryptlib-3.1_beta05.ebuild
+++ b/dev-libs/cryptlib/cryptlib-3.1_beta05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.1_beta05.ebuild,v 1.2 2004/03/14 12:28:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.1_beta05.ebuild,v 1.3 2004/06/03 16:11:31 agriffis Exp $
S=${WORKDIR}
MY_PV=${PV/./}; MY_PV=${MY_PV/_/}
@@ -30,7 +30,7 @@ src_unpack() {
src_compile() {
export SCFLAGS="-fPIC -c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
export CFLAGS="-c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
- if [ `use static` ] ; then
+ if use static ; then
emake CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || \
die "emake static failed"
fi
@@ -40,13 +40,13 @@ src_compile() {
src_install() {
dolib.so libcl.so* || die "dolib.so failed"
- if [ `use static` ] ; then
+ if use static ; then
dolib.a libcl.a || die "dolib.a failed"
fi
insinto /usr/include
doins cryptlib.h || die "doins failed"
dodoc README || die "dodoc failed"
- if [ `use doc` ] ; then
+ if use doc ; then
dodoc ${DISTDIR}/manual.pdf || die "dodoc failed (manual.pdf)"
fi
}