summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-03-19 16:33:06 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-03-19 16:33:06 +0000
commit2b1a624ac91a68a04e41bac4ae04d4aa1dc9e53e (patch)
treeb982c07adc78db7695477aa9d7748efb969435fa /dev-libs/confuse
parentVersion bumped. (diff)
downloadgentoo-2-2b1a624ac91a68a04e41bac4ae04d4aa1dc9e53e.tar.gz
gentoo-2-2b1a624ac91a68a04e41bac4ae04d4aa1dc9e53e.tar.bz2
gentoo-2-2b1a624ac91a68a04e41bac4ae04d4aa1dc9e53e.zip
Version bumped. the ebuild was submitted by Nathan Phillip Brink, bug #306295.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/confuse')
-rw-r--r--dev-libs/confuse/ChangeLog8
-rw-r--r--dev-libs/confuse/confuse-2.7.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-libs/confuse/ChangeLog b/dev-libs/confuse/ChangeLog
index 58f3ab0cbce8..f0860157aa55 100644
--- a/dev-libs/confuse/ChangeLog
+++ b/dev-libs/confuse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/confuse
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/confuse/ChangeLog,v 1.40 2010/02/13 02:46:22 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/confuse/ChangeLog,v 1.41 2010/03/19 16:33:06 matsuu Exp $
+
+*confuse-2.7 (19 Mar 2010)
+
+ 19 Mar 2010; MATSUU Takuto <matsuu@gentoo.org> +confuse-2.7.ebuild:
+ Version bumped. the ebuild was submitted by Nathan Phillip Brink, bug
+ #306295.
13 Feb 2010; MATSUU Takuto <matsuu@gentoo.org> -confuse-2.6.ebuild,
-confuse-2.6-r2.ebuild:
diff --git a/dev-libs/confuse/confuse-2.7.ebuild b/dev-libs/confuse/confuse-2.7.ebuild
new file mode 100644
index 000000000000..be2d172bc502
--- /dev/null
+++ b/dev-libs/confuse/confuse-2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/confuse/confuse-2.7.ebuild,v 1.1 2010/03/19 16:33:06 matsuu Exp $
+
+EAPI=2
+
+DESCRIPTION="a configuration file parser library"
+HOMEPAGE="http://www.nongnu.org/confuse/"
+SRC_URI="mirror://nongnu/confuse/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls"
+
+DEPEND="sys-devel/flex
+ sys-devel/libtool
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_configure() {
+ # examples are normally compiled but not installed. They
+ # fail during a mingw crosscompile.
+ econf \
+ --enable-shared \
+ --disable-examples \
+ $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ doman doc/man/man3/*.3 || die
+ dodoc AUTHORS NEWS README || die
+ dohtml doc/html/* || die
+
+ docinto examples || die
+ dodoc examples/*.{c,conf} || die
+}