summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-12-05 03:58:24 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-12-05 03:58:24 +0000
commit15c3f83a0441a603c2d658861f6515118513b695 (patch)
tree803924eda5fc63a263e38b1baba4a36b2a8283b9 /dev-libs/bitset
parentRemove temp Qt 4.8.4 mask (diff)
downloadgentoo-2-15c3f83a0441a603c2d658861f6515118513b695.tar.gz
gentoo-2-15c3f83a0441a603c2d658861f6515118513b695.tar.bz2
gentoo-2-15c3f83a0441a603c2d658861f6515118513b695.zip
Initial commit wrt bug #445880. Ebuild by Johan Bergström. He will maintain this package through proxy maintainers
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/bitset')
-rw-r--r--dev-libs/bitset/ChangeLog11
-rw-r--r--dev-libs/bitset/bitset-2.8.1.ebuild37
-rw-r--r--dev-libs/bitset/metadata.xml19
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/bitset/ChangeLog b/dev-libs/bitset/ChangeLog
new file mode 100644
index 000000000000..41677ea88f91
--- /dev/null
+++ b/dev-libs/bitset/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-libs/bitset
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/ChangeLog,v 1.1 2012/12/05 03:58:24 pinkbyte Exp $
+
+*bitset-2.8.1 (05 Dec 2012)
+
+ 05 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> +bitset-2.8.1.ebuild,
+ +metadata.xml:
+ Initial commit wrt bug #445880. Ebuild by Johan Bergström. He will maintain
+ this package through proxy maintainers
+
diff --git a/dev-libs/bitset/bitset-2.8.1.ebuild b/dev-libs/bitset/bitset-2.8.1.ebuild
new file mode 100644
index 000000000000..cda522f28676
--- /dev/null
+++ b/dev-libs/bitset/bitset-2.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/bitset-2.8.1.ebuild,v 1.1 2012/12/05 03:58:24 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A compressed bitset with supporting data structures and algorithms"
+HOMEPAGE="http://github.com/chriso/bitset"
+SRC_URI="mirror://github/chriso/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="jemalloc static-libs tcmalloc"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="tcmalloc? ( !jemalloc )
+ jemalloc? ( !tcmalloc )"
+
+DOCS=( README.md )
+
+src_configure() {
+ econf \
+ $(use_with jemalloc) \
+ $(use_with tcmalloc) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}
diff --git a/dev-libs/bitset/metadata.xml b/dev-libs/bitset/metadata.xml
new file mode 100644
index 000000000000..a82436032836
--- /dev/null
+++ b/dev-libs/bitset/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <use>
+ <flag name="jemalloc">Use <pkg>dev-libs/jemalloc</pkg> for allocations</flag>
+ <flag name="tcmalloc">Use tcmalloc from <pkg>dev-util/google-perftools</pkg> for allocations</flag>
+ </use>
+</pkgmetadata>