summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 16:07:55 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 16:07:55 +0000
commit4c5024c0636adc7449197e081692abb5a598fea7 (patch)
tree1922a3eb60501f2df410bfa119885e6985e6c32b /dev-libs/atk
parentStable for HPPA (bug #81958). (diff)
downloadgentoo-2-4c5024c0636adc7449197e081692abb5a598fea7.tar.gz
gentoo-2-4c5024c0636adc7449197e081692abb5a598fea7.tar.bz2
gentoo-2-4c5024c0636adc7449197e081692abb5a598fea7.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/atk')
-rw-r--r--dev-libs/atk/ChangeLog7
-rw-r--r--dev-libs/atk/atk-2.8.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-libs/atk/ChangeLog b/dev-libs/atk/ChangeLog
index ccf5b043dbfa..5914fbf61355 100644
--- a/dev-libs/atk/ChangeLog
+++ b/dev-libs/atk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/atk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.259 2013/03/28 15:49:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.260 2013/03/28 16:07:55 pacho Exp $
+
+*atk-2.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +atk-2.8.0.ebuild:
+ Version bump for Gnome 3.8
28 Mar 2013; Agostino Sarubbo <ago@gentoo.org> atk-2.6.0.ebuild:
Stable for arm, wrt bug #458984
diff --git a/dev-libs/atk/atk-2.8.0.ebuild b/dev-libs/atk/atk-2.8.0.ebuild
new file mode 100644
index 000000000000..fef678789aed
--- /dev/null
+++ b/dev-libs/atk/atk-2.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-2.8.0.ebuild,v 1.1 2013/03/28 16:07:55 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="http://projects.gnome.org/accessibility/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="+introspection nls test"
+
+RDEPEND=">=dev-libs/glib-2.31.2:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ G2CONF="${G2CONF} $(use_enable introspection)"
+
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+}