summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-07-04 19:05:51 +0000
committerPacho Ramos <pacho@gentoo.org>2015-07-04 19:05:51 +0000
commit2198ca4e28369e49534cdcc10268691d99b8aca8 (patch)
treeb070f6da36ee7c89f14eb1f1582fec2c1c9ee348 /dev-libs/appstream-glib
parentStable for amd64, arm and x86. Bug #552208. (diff)
downloadgentoo-2-2198ca4e28369e49534cdcc10268691d99b8aca8.tar.gz
gentoo-2-2198ca4e28369e49534cdcc10268691d99b8aca8.tar.bz2
gentoo-2-2198ca4e28369e49534cdcc10268691d99b8aca8.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/appstream-glib')
-rw-r--r--dev-libs/appstream-glib/ChangeLog7
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.4.0.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-libs/appstream-glib/ChangeLog b/dev-libs/appstream-glib/ChangeLog
index 1b49dd96242f..76bfcba60886 100644
--- a/dev-libs/appstream-glib/ChangeLog
+++ b/dev-libs/appstream-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/appstream-glib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/appstream-glib/ChangeLog,v 1.22 2015/06/20 19:18:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/appstream-glib/ChangeLog,v 1.23 2015/07/04 19:05:51 pacho Exp $
+
+*appstream-glib-0.4.0 (04 Jul 2015)
+
+ 04 Jul 2015; Pacho Ramos <pacho@gentoo.org> +appstream-glib-0.4.0.ebuild:
+ Version bump
20 Jun 2015; Pacho Ramos <pacho@gentoo.org> appstream-glib-0.3.4.ebuild:
sparc keyword, bug #523924
diff --git a/dev-libs/appstream-glib/appstream-glib-0.4.0.ebuild b/dev-libs/appstream-glib/appstream-glib-0.4.0.ebuild
new file mode 100644
index 000000000000..2a93e8e49cdd
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.4.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/appstream-glib/appstream-glib-0.4.0.ebuild,v 1.1 2015/07/04 19:05:51 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="http://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="http://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/7"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection nls"
+
+# FIXME: yaml is optional with --enable-dep11 but not
+# properly handled in autofoo bug#????
+RDEPEND="
+ app-arch/gcab
+ app-arch/libarchive
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.16.1:2
+ >=media-libs/fontconfig-2.11
+ >=media-libs/freetype-2.4:2
+ >=net-libs/libsoup-2.24:2.4
+ >=x11-libs/gdk-pixbuf-2.14:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ dev-libs/libyaml
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+"
+# ${PN} superseeds appdata-tools, require dummy package until all ebuilds
+# are migrated to appstream-glib
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1
+"
+PDEPEND=">=dev-util/appdata-tools-0.1.8-r1"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-builder \
+ --disable-ostree \
+ --disable-rpm \
+ --disable-static \
+ --enable-dep11 \
+ --enable-man \
+ $(use_enable nls) \
+ $(use_enable introspection) \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}