summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-06 13:37:27 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-06 13:37:27 +0000
commit5df5eec06b12559a0227d93d50e587d79158546a (patch)
treee6f1e54e400da9db097451fa848b0a33124a9523 /dev-libs/DirectFB
parentnew eclass to support ebuilds from ruby-gnome2.sf.net (diff)
downloadgentoo-2-5df5eec06b12559a0227d93d50e587d79158546a.tar.gz
gentoo-2-5df5eec06b12559a0227d93d50e587d79158546a.tar.bz2
gentoo-2-5df5eec06b12559a0227d93d50e587d79158546a.zip
fix quicktime deps #25784
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.12.ebuild14
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild12
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.16.ebuild6
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.17.ebuild6
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.18.ebuild6
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.19-r1.ebuild6
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.19.ebuild6
7 files changed, 24 insertions, 32 deletions
diff --git a/dev-libs/DirectFB/DirectFB-0.9.12.ebuild b/dev-libs/DirectFB/DirectFB-0.9.12.ebuild
index 60b8c2429ca7..0a5847e1ef28 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.12.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.12.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.12.ebuild,v 1.12 2003/08/04 21:21:11 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.12.ebuild,v 1.13 2003/08/06 13:34:08 vapier Exp $
-IUSE="gif quicktime mpeg png truetype flash jpeg mmx"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="DirectFB is a thin library on top of the Linux framebuffer devices"
+DESCRIPTION="a thin library that sits on top of the Linux framebuffer devices"
+HOMEPAGE="http://www.directfb.org/"
SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-HOMEPAGE="http://www.directfb.org"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 sparc ppc alpha"
+IUSE="gif quicktime mpeg png truetype flash jpeg mmx"
DEPEND="dev-lang/perl
gif? ( media-libs/giflib )
@@ -23,7 +21,6 @@ DEPEND="dev-lang/perl
quicktime? ( virtual/quicktime )"
# avi? ( >=media-video/avifile-0.7.4.20020426-r2 )"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -34,7 +31,6 @@ src_unpack() {
}
src_compile() {
-
local myconf=""
# Bug in the ./configure script that breaks if you
diff --git a/dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild b/dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild
index b002882a5333..230288e58cba 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild,v 1.6 2003/07/12 09:22:21 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild,v 1.7 2003/08/06 13:34:08 vapier Exp $
-IUSE="jpeg gif png truetype mpeg mmx sse"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
+IUSE="jpeg gif png truetype mpeg mmx sse"
DEPEND=">=sys-apps/sed-4
dev-lang/perl
@@ -20,8 +18,6 @@ DEPEND=">=sys-apps/sed-4
jpeg? ( media-libs/jpeg )
mpeg? ( media-libs/libmpeg3 )
truetype? ( >=media-libs/freetype-2.0.1 )"
-
-
PDEPEND="=dev-libs/DirectFB-extra-${PV}*"
src_unpack() {
diff --git a/dev-libs/DirectFB/DirectFB-0.9.16.ebuild b/dev-libs/DirectFB/DirectFB-0.9.16.ebuild
index 70a5053c331b..19fe6e7df6f9 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.16.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.16.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.16.ebuild,v 1.5 2003/08/04 21:21:11 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.16.ebuild,v 1.6 2003/08/06 13:34:08 vapier Exp $
DESCRIPTION="thin library on top of the Linux framebuffer devices"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
IUSE="gif quicktime mpeg png truetype flash jpeg mmx sse sdl"
diff --git a/dev-libs/DirectFB/DirectFB-0.9.17.ebuild b/dev-libs/DirectFB/DirectFB-0.9.17.ebuild
index b60f512735e5..85985e03df49 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.17.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.17.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.17.ebuild,v 1.3 2003/07/12 09:22:21 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.17.ebuild,v 1.4 2003/08/06 13:34:08 vapier Exp $
DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
IUSE="jpeg gif png truetype mpeg mmx sse"
diff --git a/dev-libs/DirectFB/DirectFB-0.9.18.ebuild b/dev-libs/DirectFB/DirectFB-0.9.18.ebuild
index b6271016a480..76c2425333a9 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.18.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.18.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.18.ebuild,v 1.3 2003/08/06 06:25:06 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.18.ebuild,v 1.4 2003/08/06 13:34:08 vapier Exp $
DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha hppa"
IUSE="jpeg gif png truetype mpeg mmx sse"
diff --git a/dev-libs/DirectFB/DirectFB-0.9.19-r1.ebuild b/dev-libs/DirectFB/DirectFB-0.9.19-r1.ebuild
index a5b5f07c8680..aac1b294af1f 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.19-r1.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.19-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.19-r1.ebuild,v 1.1 2003/08/05 12:02:51 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.19-r1.ebuild,v 1.2 2003/08/06 13:34:08 vapier Exp $
DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha hppa"
IUSE="jpeg gif png truetype mpeg mmx sse"
diff --git a/dev-libs/DirectFB/DirectFB-0.9.19.ebuild b/dev-libs/DirectFB/DirectFB-0.9.19.ebuild
index 743223bc0bf4..96433c06df89 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.19.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.19.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.19.ebuild,v 1.1 2003/08/04 20:21:02 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.19.ebuild,v 1.2 2003/08/06 13:34:08 vapier Exp $
DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha hppa"
IUSE="jpeg gif png truetype mpeg mmx sse"