summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-07 20:15:45 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-07 20:15:45 +0000
commit07e1381efdc48a8aa1baba9e6714dbbd705184ee (patch)
treef91a2e16c6f2f9276ff7f20d2a0b434ad1546dbd /dev-libs/DirectFB
parentfixed slot operator on libpng , bug 456084 (diff)
downloadgentoo-2-07e1381efdc48a8aa1baba9e6714dbbd705184ee.tar.gz
gentoo-2-07e1381efdc48a8aa1baba9e6714dbbd705184ee.tar.bz2
gentoo-2-07e1381efdc48a8aa1baba9e6714dbbd705184ee.zip
version bump wrt #452264
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/ChangeLog11
-rw-r--r--dev-libs/DirectFB/DirectFB-1.6.3.ebuild137
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.6.3-build.patch33
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.6.3-flags.patch11
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.6.3-pkgconfig.patch22
-rw-r--r--dev-libs/DirectFB/metadata.xml30
6 files changed, 232 insertions, 12 deletions
diff --git a/dev-libs/DirectFB/ChangeLog b/dev-libs/DirectFB/ChangeLog
index 2531af7a9b35..4f228eb60d1b 100644
--- a/dev-libs/DirectFB/ChangeLog
+++ b/dev-libs/DirectFB/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/DirectFB
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.129 2012/01/27 20:11:51 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.130 2013/02/07 20:15:45 hasufell Exp $
+
+*DirectFB-1.6.3 (07 Feb 2013)
+
+ 07 Feb 2013; Julian Ospald <hasufell@gentoo.org> +DirectFB-1.6.3.ebuild,
+ +files/DirectFB-1.6.3-build.patch, +files/DirectFB-1.6.3-flags.patch,
+ +files/DirectFB-1.6.3-pkgconfig.patch, metadata.xml:
+ version bump wrt #452264
27 Jan 2012; Tupone Alfredo <tupone@gentoo.org> DirectFB-1.4.9-r1.ebuild,
metadata.xml:
diff --git a/dev-libs/DirectFB/DirectFB-1.6.3.ebuild b/dev-libs/DirectFB/DirectFB-1.6.3.ebuild
new file mode 100644
index 000000000000..2f81512cbf5d
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-1.6.3.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.6.3.ebuild,v 1.1 2013/02/07 20:15:45 hasufell Exp $
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+# Map Gentoo IUSE expand vars to DirectFB drivers
+# echo `sed -n '/Possible gfxdrivers are:/,/^$/{/Possible/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
+I_TO_D_intel="i810,i830"
+I_TO_D_mga="matrox"
+I_TO_D_r128="ati128"
+I_TO_D_s3="unichrome"
+I_TO_D_sis="sis315"
+I_TO_D_via="cle266"
+# cyber5k davinci ep9x gl omap pxa3xx sh772x
+IUSE_VIDEO_CARDS=" intel mach64 mga neomagic nsc nvidia r128 radeon s3 savage sis tdfx via vmware"
+IUV=${IUSE_VIDEO_CARDS// / video_cards_}
+# echo `sed -n '/Possible inputdrivers are:/,/^$/{/\(Possible\|^input\)/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
+I_TO_D_elo2300="elo-input"
+I_TO_D_evdev="linuxinput"
+I_TO_D_mouse="ps2mouse serialmouse"
+# dbox2remote dreamboxremote gunze h3600_ts penmount sonypijogdial ucb1x00 wm97xx zytronic
+IUSE_INPUT_DEVICES=" dynapro elo2300 evdev input_hub joystick keyboard lirc mouse mutouch tslib"
+IUD=${IUSE_INPUT_DEVICES// / input_devices_}
+
+DESCRIPTION="Thin library on top of the Linux framebuffer devices"
+HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://directfb.org/downloads/Core/${PN}-${PV:0:3}/${P}.tar.gz
+ http://directfb.org/downloads/Old/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
+IUSE="bmp debug dynload doc fbcon gif gles2 imlib2 jpeg jpeg2k mmx mng mpeg2 multicore opengl png pnm sdl sse static-libs svg truetype v4l vdpau X zlib ${IUV} ${IUD}"
+REQUIRED_USE="gles2? ( opengl )"
+
+# gstreamer useflag broken
+# gstreamer? ( media-libs/FusionSound media-libs/gst-plugins-base:0.10 )
+# $(use_enable gstreamer) \
+RDEPEND="
+ gif? ( media-libs/giflib )
+ imlib2? ( media-libs/imlib2 )
+ jpeg? ( virtual/jpeg )
+ jpeg2k? ( media-libs/jasper[jpeg] )
+ mng? ( media-libs/libmng )
+ opengl? ( media-libs/mesa[gbm,egl,gles2?] x11-libs/libdrm )
+ png? ( media-libs/libpng:0 )
+ sdl? ( media-libs/libsdl )
+ svg? ( x11-libs/libsvg-cairo )
+ truetype? ( >=media-libs/freetype-2.0.1 )
+ vdpau? ( x11-proto/xproto x11-libs/libX11 x11-libs/libXext x11-libs/libvdpau )
+ X? ( x11-libs/libXext x11-libs/libX11 )
+ zlib? ( sys-libs/zlib ) "
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xextproto x11-proto/xproto )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-pkgconfig.patch \
+ "${FILESDIR}"/${P}-build.patch
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+driver_list() {
+ local pfx=$1
+ local dev devs map
+ shift
+ for dev in "$@" ; do
+ use ${pfx}_${dev} || continue
+ map="I_TO_D_${dev}"
+ devs=${devs:+${devs},}${!map:-${dev}}
+ done
+ echo ${devs:-none}
+}
+
+src_configure() {
+ local sdlconf="--disable-sdl"
+ if use sdl ; then
+ # since SDL can link against DirectFB and trigger a
+ # dependency loop, only link against SDL if it isn't
+ # broken #61592
+ echo 'int main(){}' > sdl-test.c
+ $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
+ && sdlconf="--enable-sdl" \
+ || ewarn "Disabling SDL since libSDL.so is broken"
+ fi
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable X x11) \
+ $(use_enable fbcon fbdev) \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable mng) \
+ $(use_enable gif) \
+ $(use_enable imlib2) \
+ $(use_enable pnm) \
+ $(use_enable svg) \
+ $(use_enable mpeg2) \
+ $(use_enable bmp) \
+ $(use_enable jpeg2k jpeg2000) \
+ $(use_enable truetype freetype) \
+ $(use_enable debug) \
+ $(use_enable zlib) \
+ --disable-video4linux \
+ $(use_enable v4l video4linux2) \
+ $(use_enable vdpau x11vdpau) \
+ $(use_enable multicore) \
+ $(use_enable dynload) \
+ $(use_enable opengl mesa) \
+ ${sdlconf} \
+ --with-gfxdrivers="$(driver_list video_cards ${IUSE_VIDEO_CARDS}) $(usex opengl "gl" "") $(usex vdpau "vdpau" "") $(usex gles2 "gles2" "")" \
+ --with-inputdrivers="$(driver_list input_devices ${IUSE_INPUT_DEVICES})" \
+ --disable-vnc
+}
+
+src_install() {
+ default
+ dodoc fb.modes
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ ewarn "Each DirectFB update breaks DirectFB related applications."
+ ewarn "Please run \"revdep-rebuild\" which can be"
+ ewarn "found by emerging the package 'gentoolkit'."
+ ewarn
+ ewarn "If you have an ALPS touchpad, then you might get your mouse"
+ ewarn "unexpectedly set in absolute mode in all DirectFB applications."
+ ewarn "This can be fixed by removing linuxinput from INPUT_DEVICES."
+}
diff --git a/dev-libs/DirectFB/files/DirectFB-1.6.3-build.patch b/dev-libs/DirectFB/files/DirectFB-1.6.3-build.patch
new file mode 100644
index 000000000000..241875187941
--- /dev/null
+++ b/dev-libs/DirectFB/files/DirectFB-1.6.3-build.patch
@@ -0,0 +1,33 @@
+--- DirectFB-1.6.3/interfaces/IDirectFBImageProvider/Makefile.am
++++ DirectFB-1.6.3/interfaces/IDirectFBImageProvider/Makefile.am
+@@ -59,15 +59,15 @@
+ MPEG2_PROVIDER =
+ endif
+
+-INCLUDES = \
++AM_CPPFLAGS =
++AM_CPPFLAGS = \
+ -I$(top_builddir)/include \
+ -I$(top_builddir)/lib \
+ -I$(top_builddir)/src \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/lib \
+- -I$(top_srcdir)/src
+-
+-AM_CPPFLAGS = -DDATADIR=\"${RUNTIME_SYSROOT}@DATADIR@\" $(LIBJPEG_CFLAGS) $(LIBPNG_CFLAGS)
++ -I$(top_srcdir)/src \
++ -DDATADIR=\"${RUNTIME_SYSROOT}@DATADIR@\" $(LIBJPEG_CFLAGS) $(LIBPNG_CFLAGS) $(SVG_CFLAGS)
+
+ idirectfbimageprovider_LTLIBRARIES = \
+ libidirectfbimageprovider_dfiff.la \
+--- DirectFB-1.6.3/configure.in
++++ DirectFB-1.6.3/configure.in
+@@ -980,7 +980,7 @@
+ dnl Test for libmng
+ MNG=no
+
+-AC_ARG_ENABLE(mngg,
++AC_ARG_ENABLE(mng,
+ AC_HELP_STRING([--enable-mng],
+ [build MNG image provider @<:@default=yes@:>@]),
+ [], [enable_mng=yes])
diff --git a/dev-libs/DirectFB/files/DirectFB-1.6.3-flags.patch b/dev-libs/DirectFB/files/DirectFB-1.6.3-flags.patch
new file mode 100644
index 000000000000..d20b05bf816f
--- /dev/null
+++ b/dev-libs/DirectFB/files/DirectFB-1.6.3-flags.patch
@@ -0,0 +1,11 @@
+--- DirectFB-1.6.3/configure.in
++++ DirectFB-1.6.3/configure.in
+@@ -457,7 +457,7 @@
+ [enable debugging @<:@default=no@:>@]),
+ [], [enable_debug=no])
+ if test "$enable_debug" = "yes"; then
+- CFLAGS="-g3 -O0 -fno-inline -Wno-inline $CFLAGS"
++ CFLAGS="-fno-inline -Wno-inline $CFLAGS"
+ DIRECT_BUILD_DEBUG=1
+ else
+ DIRECT_BUILD_DEBUG=0
diff --git a/dev-libs/DirectFB/files/DirectFB-1.6.3-pkgconfig.patch b/dev-libs/DirectFB/files/DirectFB-1.6.3-pkgconfig.patch
new file mode 100644
index 000000000000..2c71bc96f9e6
--- /dev/null
+++ b/dev-libs/DirectFB/files/DirectFB-1.6.3-pkgconfig.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/200661
+
+--- DirectFB/directfb-config.in
++++ DirectFB/directfb-config.in
+@@ -300,7 +300,7 @@
+ libs="$libs -ldirectfb -lfusion -ldirect @THREADLIB@"
+
+ if test -n "$echo_static"; then
+- libs="$libs @DYNLIB@ @ZLIB_LIBS@"
++ libs="$libs @DYNLIB@ @ZLIB_LIBS@ @SYSFS_LIBS@"
+ fi
+ fi
+
+--- DirectFB/directfb.pc.in
++++ DirectFB/directfb.pc.in
+@@ -9,5 +9,5 @@
+ Version: @VERSION@
+ Requires: @DEP_VOODOO@ fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @OSX_LIBS@
+-Libs.private: -L${libdir} @LIBM@ @DYNLIB@ @ZLIB_LIBS@
++Libs.private: -L${libdir} @LIBM@ @DYNLIB@ @ZLIB_LIBS@ @SYSFS_LIBS@
+ Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
diff --git a/dev-libs/DirectFB/metadata.xml b/dev-libs/DirectFB/metadata.xml
index 9837821b420c..d0c17ab1d245 100644
--- a/dev-libs/DirectFB/metadata.xml
+++ b/dev-libs/DirectFB/metadata.xml
@@ -1,14 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>games</herd>
-<longdescription>
-DirectFB is a thin library that provides hardware graphics acceleration,
-input device handling and abstraction, integrated windowing system with
-support for translucent windows and multiple display layers on top of the
-Linux Framebuffer Device. It is a complete hardware abstraction layer with
-software fallbacks for every graphics operation that is not supported by the
-underlying hardware. DirectFB adds graphical power to embedded systems and
-sets a new standard for graphics under Linux
-</longdescription>
+ <herd>games</herd>
+ <longdescription>
+ DirectFB is a thin library that provides hardware graphics acceleration,
+ input device handling and abstraction, integrated windowing system with
+ support for translucent windows and multiple display layers on top of the
+ Linux Framebuffer Device. It is a complete hardware abstraction layer with
+ software fallbacks for every graphics operation that is not supported by the
+ underlying hardware. DirectFB adds graphical power to embedded systems and
+ sets a new standard for graphics under Linux
+ </longdescription>
+ <use>
+ <flag name="bmp">build BMP image provider</flag>
+ <flag name="dynload">enable dynload support</flag>
+ <flag name="gles2">build gles2 gfxdriver</flag>
+ <flag name="imlib2">build Imlib2 image provider</flag>
+ <flag name="mpeg2">build MPEG2 image provider</flag>
+ <flag name="multicore">enable multicore support</flag>
+ <flag name="pnm">build PNM (PBM/PGM/PPM) image provider</flag>
+ <flag name="input_devices_input_hub">build input driver input_hub</flag>
+ </use>
</pkgmetadata>