summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-10-12 19:33:45 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-10-12 19:33:45 +0000
commitdf15d98573cc1f172f7d50a86bae2a0b4ab8fc0d (patch)
tree5c465b4b2cd92c827bee05d7bfb2ce7b4a13442c /dev-lang
parentFixed to compile with jikes, Thanks too Dan <dan@intuitivelyobvious.net> for ... (diff)
downloadgentoo-2-df15d98573cc1f172f7d50a86bae2a0b4ab8fc0d.tar.gz
gentoo-2-df15d98573cc1f172f7d50a86bae2a0b4ab8fc0d.tar.bz2
gentoo-2-df15d98573cc1f172f7d50a86bae2a0b4ab8fc0d.zip
Strip unsupported flags.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild3
-rw-r--r--dev-lang/ocaml/ocaml-3.08.1.ebuild3
-rw-r--r--dev-lang/ocaml/ocaml-3.08.ebuild3
4 files changed, 11 insertions, 4 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 2abe16b406ed..6e9853b42ef0 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.47 2004/08/22 11:28:19 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.48 2004/10/12 19:33:45 mattam Exp $
+
+ 12 Oct 2004; Matthieu Sozeau <mattam@gentoo.org> ocaml-3.07-r1.ebuild,
+ ocaml-3.08.1.ebuild, ocaml-3.08.ebuild:
+ Add strip-flags to remove -O3 and other unsupported ones etc..
22 Aug 2004; Travis Tilley <lv@gentoo.org> ocaml-3.08.ebuild:
stable on amd64
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index e4d86b4427a0..07f460df2c70 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.24 2004/09/16 01:42:08 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.25 2004/10/12 19:33:45 mattam Exp $
inherit flag-o-matic eutils
@@ -35,6 +35,7 @@ src_unpack() {
src_compile() {
filter-flags "-fstack-protector"
+ strip-flags
local myconf
use tcltk || myconf="-no-tk"
diff --git a/dev-lang/ocaml/ocaml-3.08.1.ebuild b/dev-lang/ocaml/ocaml-3.08.1.ebuild
index 1580f12e76a4..c61dd2f4fc58 100644
--- a/dev-lang/ocaml/ocaml-3.08.1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.08.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.1.ebuild,v 1.2 2004/09/16 01:42:08 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.1.ebuild,v 1.3 2004/10/12 19:33:45 mattam Exp $
inherit flag-o-matic eutils
@@ -26,6 +26,7 @@ pkg_setup() {
src_compile() {
filter-flags "-fstack-protector"
+ strip-flags
local myconf
use tcltk || myconf="-no-tk"
diff --git a/dev-lang/ocaml/ocaml-3.08.ebuild b/dev-lang/ocaml/ocaml-3.08.ebuild
index cf49b3cef262..33e48715cd05 100644
--- a/dev-lang/ocaml/ocaml-3.08.ebuild
+++ b/dev-lang/ocaml/ocaml-3.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.6 2004/09/16 01:42:08 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.7 2004/10/12 19:33:45 mattam Exp $
inherit flag-o-matic eutils
@@ -28,6 +28,7 @@ pkg_setup() {
src_compile() {
filter-flags "-fstack-protector"
+ strip-flags
local myconf
use tcltk || myconf="-no-tk"