summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-02-21 14:43:00 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-02-21 14:43:00 +0000
commitbdbcf37960ca3a4766dd6d0c0ec3ec1795069c60 (patch)
tree63b5246708958c419cf0986b8b75905539913bf7 /dev-lang
parentBump (diff)
downloadgentoo-2-bdbcf37960ca3a4766dd6d0c0ec3ec1795069c60.tar.gz
gentoo-2-bdbcf37960ca3a4766dd6d0c0ec3ec1795069c60.tar.bz2
gentoo-2-bdbcf37960ca3a4766dd6d0c0ec3ec1795069c60.zip
use the wxwidgets USE flag instead of wxwindows, see bug 305349 by Ciprian Ciubotariu <cheepeero AT gmx DOT net>
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/ChangeLog9
-rw-r--r--dev-lang/erlang/erlang-13.2.2.ebuild12
-rw-r--r--dev-lang/erlang/erlang-13.2.3.ebuild12
3 files changed, 19 insertions, 14 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index 0dab9146ca0b..ca7843640e9d 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/erlang
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.179 2009/12/29 18:23:34 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.180 2010/02/21 14:43:00 fauli Exp $
+
+ 21 Feb 2010; Christian Faulhammer <fauli@gentoo.org> erlang-13.2.2.ebuild,
+ erlang-13.2.3.ebuild:
+ use the wxwidgets USE flag instead of wxwindows, see bug 305349 by Ciprian
+ Ciubotariu <cheepeero AT gmx DOT net>
29 Dec 2009; Christian Faulhammer <fauli@gentoo.org>
-erlang-12.2.5-r1.ebuild, -files/erlang-12.2.5-amd64_segfault.patch,
diff --git a/dev-lang/erlang/erlang-13.2.2.ebuild b/dev-lang/erlang/erlang-13.2.2.ebuild
index 9ed792803da8..71a7060babc3 100644
--- a/dev-lang/erlang/erlang-13.2.2.ebuild
+++ b/dev-lang/erlang/erlang-13.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-13.2.2.ebuild,v 1.8 2009/12/29 17:48:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-13.2.2.ebuild,v 1.9 2010/02/21 14:43:00 fauli Exp $
EAPI=2
WX_GTK_VER="2.8"
@@ -30,7 +30,7 @@ SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
LICENSE="EPL"
SLOT="0"
KEYWORDS="alpha amd64 ~arm ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp sctp ssl tk wxwindows"
+IUSE="doc emacs hipe java kpoll odbc smp sctp ssl tk wxwidgets"
RDEPEND=">=dev-lang/perl-5.6.1
ssl? ( >=dev-libs/openssl-0.9.7d )
@@ -38,7 +38,7 @@ RDEPEND=">=dev-lang/perl-5.6.1
java? ( >=virtual/jdk-1.2 )
odbc? ( dev-db/unixODBC )"
DEPEND="${RDEPEND}
- wxwindows? ( x11-libs/wxGTK:2.8[opengl] )
+ wxwidgets? ( x11-libs/wxGTK:2.8[opengl] )
sctp? ( net-misc/lksctp-tools )
tk? ( dev-lang/tk )"
@@ -47,13 +47,13 @@ S="${WORKDIR}/${MY_P}"
SITEFILE=50${PN}-gentoo.el
pkg_setup() {
- use wxwindows && wxwidgets_pkg_setup
+ use wxwidgets && wxwidgets_pkg_setup
}
src_prepare() {
use odbc || sed -i 's: odbc : :' lib/Makefile
- if ! use wxwindows; then
+ if ! use wxwidgets; then
sed -i 's: wx : :' lib/Makefile
rm -rf lib/wx
fi
diff --git a/dev-lang/erlang/erlang-13.2.3.ebuild b/dev-lang/erlang/erlang-13.2.3.ebuild
index f214f67ec820..bd148b09b027 100644
--- a/dev-lang/erlang/erlang-13.2.3.ebuild
+++ b/dev-lang/erlang/erlang-13.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-13.2.3.ebuild,v 1.1 2009/12/10 21:58:07 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-13.2.3.ebuild,v 1.2 2010/02/21 14:43:00 fauli Exp $
EAPI=2
WX_GTK_VER="2.8"
@@ -30,7 +30,7 @@ SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
LICENSE="EPL"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp sctp ssl tk wxwindows"
+IUSE="doc emacs hipe java kpoll odbc smp sctp ssl tk wxwidgets"
RDEPEND=">=dev-lang/perl-5.6.1
ssl? ( >=dev-libs/openssl-0.9.7d )
@@ -38,7 +38,7 @@ RDEPEND=">=dev-lang/perl-5.6.1
java? ( >=virtual/jdk-1.2 )
odbc? ( dev-db/unixODBC )"
DEPEND="${RDEPEND}
- wxwindows? ( x11-libs/wxGTK:2.8[opengl] )
+ wxwidgets? ( x11-libs/wxGTK:2.8[opengl] )
sctp? ( net-misc/lksctp-tools )
tk? ( dev-lang/tk )"
@@ -47,13 +47,13 @@ S="${WORKDIR}/${MY_P}"
SITEFILE=50${PN}-gentoo.el
pkg_setup() {
- use wxwindows && wxwidgets_pkg_setup
+ use wxwidgets && wxwidgets_pkg_setup
}
src_prepare() {
use odbc || sed -i 's: odbc : :' lib/Makefile
- if ! use wxwindows; then
+ if ! use wxwidgets; then
sed -i 's: wx : :' lib/Makefile
rm -rf lib/wx
fi